Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Cannot connect over 9600 bps on any COM port using any modem !!

Posted on 1997-06-13
5
197 Views
Last Modified: 2013-12-16
I have a US Robotics 33.6 v.Everything PCMCIA modem (on COM4) that I can connect to ANY other modem at only 9600 bps.  I have tried an external USR Sportster 28k on COM2 and had the same results.  I have tried ALL the "Maximum Speed" settings in the modem properties, with & without Hardware Flow Control.

My communications driver is comm.drv  5856 bytes  dated: 7/11/1995 09:50am.

I have also tried the Modem device via the Device Manager in the System icon in the Control Panel... no luck.

Are there any useful shareware diagnostic utilities that could shed some light on this problem?  Any ideas would be appreciated.

Please reply to:  hooligan@usa.net

Thanks!

hooligan@usa.net
0
Comment
Question by:lebaron
  • 4
5 Comments
 
LVL 14

Accepted Solution

by:
smeebud earned 100 total points
ID: 1748798
I assume you do have a 16550 UART CHIP. Check MSD to see what the UART  is. Sometimes systems somehow forget this or it GOES BAD. I've had it happen with the same symtoms as yours.
Other-wise, check your advanced port settings in "device manager" to see if your uart is correct.
Or go to USR home page, they have diags there.
http://www.usr.com/
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748799
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748800
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748801
Diagnostic you say:
http://www.dlr.de/fresh/pc/src/misc/.warix/ctsspu22.zip.html
ctsspu22.zip - COM port & modem setup & diagnostic utilities
0
 

Expert Comment

by:LouA
ID: 1748802
What IRQ are you set-up on?  Did you go in the Device Manager and try and change the configuration, since you did change to use COM 4.  Most modems use COM 2.  Is the modem set up at its MAX speed, use 57600. Check in Properties, port settings, is the box for "use FIFO buffers (requires 16550 compatible UART)" checked. Still in properties, click advanced  the following should be checked "Use error control, Use flow control, compress data and the radio dial for Hardware(RTS/CTS) also checked (dot). Modulation type: standard.  Also check out your bias set up this should be ok, if the modem is working.  
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently Microsoft released a brand new function called CONCAT. It's supposed to replace its predecessor CONCATENATE. But how does it work? And what's new? In this article, we take a closer look at all of this - we even included an exercise file for…
This is an article about Leadership and accepting and adapting to new challenges. It focuses mostly on upgrading to Windows 10.
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

837 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question