Solved

Sendmail Configuration

Posted on 1997-06-14
4
292 Views
Last Modified: 2013-12-15

I'm running a P-100 and 386 over Ethernet and have established connectivity (ping, telnet, etc. work in both directions).  However, I'm only able to sendmail from the 386 to the P-100.  When I run the command sendmail -vt root@my.host.name from the P-100 -> 386, I get the following
error:

root@my.host.name ... Deferred: Name server: my.host.name.: host name lookup failure

When I installed Linux, I configured sendmail w/o DNS.  I have not modified the sendmail.cf files on either host.  And there is more ...

I have configured my P-100 to connect to my ISP via PPP and when the daemon is invoked and the link established (verified with ifconfig for ppp0), I can sendmail "all day" from the P-100 to the 386 and vice-versa!

So ... what is preventing me from using sendmail from the p-100 -> 386 when pppd isn't running?

Thanks - Bill

(*** please respond via email ***)

0
Comment
Question by:elusive1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 1

Expert Comment

by:strobert
ID: 1628187
what does your /etc/hosts file look like on your P-100
also your /etc/resolve.conf and /etc/host.conf
0
 

Author Comment

by:elusive1
ID: 1628188
strobert: My domain is defined in both configuration files and I receive the same error. Was told to modify the source line NAMED_BIND 0 and recompile but that seems to be a bit overkill.
Got my ppp dial-up script to work however <grin>!
0
 
LVL 3

Accepted Solution

by:
sauron earned 50 total points
ID: 1628189
From my experience, sendmail will always try and use DNS, unless
you actually compile with it disabled. I suggest you put the IP
address and name of your 386 in you /etc/hosts file on your P100.
This may fix it. Failing that, go through your sendmail.cf file. Somewhere in ruleset 3, or another ruleset referneced by ruleset
3 (may well be set 96, depending how you generated your
sendmail.cf file) you'll probably find a rule, with a comment to
the effect that this rule canonicalizes the domain name. If you
set up another rule immediately preceding this, of the same general format, that canonicalizes your domain without using DNS, and then returns, you should be able to make it work.
0
 

Author Comment

by:elusive1
ID: 1628190
I resolved the problem by installing BSD Sendmail 8.7.5
instead of running 8.7.5

Problem Archived -> /dev/null
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question