Masquerading and diald

I have a local ethernet network with ip masquerading and diald. My problem is that when I try to gain access to a local machine diald brings up my ISP. I think that my problem is in my routing setup. My ip address's are 192.168.1.1 for the server and 192.168.1.2 for the host. My ISP account is dynamic ppp. Any help would be greatly appreciated !!!!!
wiltAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
sauronConnect With a Mentor Commented:
I had exactly the same problem as this. In 99% of cases, I have found that it's DNS traffic that causes the problem. Make sure your hosts files list all you local machines. The make sure you don't have hosts.allow or hosts.deny files clogging things up.

Many protocols do something like the following

Client quieries DNS for servers address
Client connects to server
Server does revers lookup on client to ensure that clients claimed IP address is the same as the DNS's IP address for client's hostname.

This is a security enhancement and is usually transparent, but with diald.....

the r utilities are affected by this behaviour, among other things. f you have hosts.allow and hosts.deny files containing hostnames, it does this for everything.

What you can do is run tcpdump -i ppp0 on your masquerading machine, then try something which shouldn't bring the linl up, but does. This will show you the packet traffic across the link, which should help you pinpoint it. Be aware that tcpdump itself will do DNS lookups to be able to show you hostnames not IP addresses, so you'll have some extra packets originating from the masquerading machine. There's an option to tcpdump that will tell it to show numerical IP's, and will stop this behaviour.
0
All Courses

From novice to tech pro — start learning today.