We help IT Professionals succeed at work.

Windows95 Setup question

jbr asked
Medium Priority
Last Modified: 2013-12-16
I did a Windows 95 upgrade from 3.11 on a Pentium 75 machine which had a
1GB Fujitsu IDE hard drive and I got the little yellow exclamation point
in the device manager over the primary IDE controller.  This resulted in
Windows 95 using MS-DOS compatibility mode on the C drive.  Config.sys is
empty and autoexec.bat just has a "PATH" command.  The device manager did
not list any driver as being the culprit.

I used a procedure suggested by Fujitsu to zap the partition table on the
drive and repartitioned and reformatted it.  I then reloaded Windows 3.11
and then did the upgrade to Windows 95.  I still had the yellow exclamation
point.  The IOS.LOG file says:

ESDI head mismatch
Unit number 02 going through real mode drivers

Can somebody tell me exactly what this means and how to go about fixing it?
I am not afraid to blow away everything on the disk.  Also, if the fix is
to upgrade the BIOS, how do I go about figuring out who the motherboard
manufacturer is?  I visited the amibios web page and it listed a number
of international vendors based on part of the string the BIOS prints out
at boot time and I couldn't match my string against their list.

By the way, I've already read article Q130179 in the Microsoft Knowledge Base
("Troubleshooting MS-DOS Compatibility Mode on Hard Disks") whose title
sounded promising but wasn't able to solve my problem.

Other information:

       Initing esdi_506.pdr
       Init failure esdi_506.pdr
       Initing esdi_506.pdr
       Init success esdi_506.pdr

Presumably the first pair is for the primary IDE and the second pair is for
the secondary?

The BIOS is AMIBIOS and it's banner reads
P5I437 BIOS V1.4 1995-11-06
and at the bottom it reads

The chipset seems to be an Intel SB82371FB (PIIX) and SB82437FX, but it seems
not to be an Intel board.  There are no visible company markings on the board
(which is marked "Made in China").  It is not possible for me to contact
the original vendor since the machine belongs to my son's school and the
person who purchased the machine is no longer there and nobody else knows
where the machine came from.

The BIOS is set to autodetect the drive which is the master on the primary
IDE controller.  The BIOS reports:

                  Cyl   Hd  Sec  Size
Primary master C  2114  16  63   1040MB  LBA ON   32-bit   Block mode  PIO
                                                  mode on  16 sec     mode 4

The disk drive is a Fujitsu M1614TAU manufactured May 1996.

Thanks for any advice you can give.
-- Jeff
Watch Question

To my knowledge, ESDI drives are a totally different type of drive to IDE. Do you have anyone who can loan you a hard drive to test it on?
Their is a known problem with Windows 95 accessing drives larger than 548MB or near that but that was fixed by a patch & OSR2 doesn't exhibit that problem, if you need the patch see the Microsoft web site.
I would advise you to take a note of the drive settings in the BIOS & turn off auto detect, check what the manufacturer says they should be, and enter them manually. It may be printed on the top of the drive.


Regarding Ikon's comment, as I said in my question, the drive
is a 1GB Fujitsu IDE drive.  I didn't say it was an ESDI drive.
Nevertheless, Windows 95's port driver for IDE drives is called
esdi_506.pdr.  Regarding the suggestion about turning off auto
detect, I have tried it and it makes no difference.  What I have
not tried doing is putting in head/cyl/sector values different
from what auto detect is using.  I will try calling Fujitsu to
see if they have any suggestions along these lines.

I assume you used FDISK /s to partition your drive, what where the values diplayed for c/h/s are they the same as in the CMOS settings?
You would be better off setting the hard drive to "LARGE" or "ECHS" not "LBA"  as the 1024 cyclinder recognition limit of w95 will find this BIOS setting better eliminating the W95 misread.
As for the method of loading W95, how about instead just loading 95 without 3.1 first.
If you are using either w95 upgrade CD or disks they can be installed without a prior copy of windows being on the hard drive. When windows asks to be directed to a current copy to upgrade insert the first disk of w3.1 into your A: drive and browse to there. Win95 will then proceed to install.

I'm just hanging around for the answer if you-all don't mind


Regarding compmech's proposed answer: thank you for your useful
comment.  However, it does not answer the question as to what
"head mismatch" means.  I have already solved this problem by
telling the BIOS to disable "Block Mode" which was previously
set to "auto" and was reported by the BIOS as 16 sectors.
It was not necessary to either 1) stop using LBA or
2) install the Windows 95 upgrade without installing 3.11 first.
Anyway, I appreciate your taking the time to reply.

-- Jeff

THEN double click on the system icon in the same panel and remove
all card,bios ... in the ? section, usually in the first section.


Regarding "glimmer's" proposed answer.  Again, this does not
answer the question of what "ESDI head mismatch" means.  Also,
I can't really understand what glimmer is actually suggesting
I do.  However, if it is to remove everything in the "?"
section (which I think means "unknown hardware") then I reply
that there is presently no such section.

-- Jeff
The problem is that The Heads/Sectors/cylinders that the BIOS has noted for a disk, isnt what W95 sees when it asks the disk itself. Most disks can be detected in more ways then one, if you have multiple choices of Logical COnfigurations in teh BIOS, try another one..

And a comment: W95 uses the same driver for IDE/EIDE/ESDI and even SDI (MFM) disks, since they all interface to the system in the same way.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

By disabling Block mode you have reduced the performance of your system overall.Why
LBA is for drives larger than 512Mb ... your's isn't
Further the message means exactly that the head count doesn't match the ESDI specification.A cute answer from 95 that probably appears for a few problems including yours.
My earlier answer will still be the better way to go long term.


Compmech: why do you say that "LBA is for drives larger than
512Mb ... your's isn't"?  As I mentioned in my original
question, my drive is 1GB.  I really didn't understand your
first suggestion about using LARGE or ECHS.  I thought LBA
was exactly what I was supposed to use since my drive is larger
than 512MB.

-- Jeff


j2: regarding your answer.  I guessed that Windows 95
(specifically esdi_506.pdr) was getting the drive to tell it
the head count and it did not compare with what the BIOS
told it.  But why wouldn't it?  Surely Windows 95 knows that
the BIOS will run the drive in LBA mode and therefore when
Windows 95 talks to the drive itself, it will also use LBA
mode and get the same answer for the head count.  You haven't
given a plausible explanation for why it would be different.
I also don't understand why setting Block Mode to disabled
caused the mismatch do go away.

if you go to http://www.fujitsu.com/ follow the links and you will find the excact numbers to type in your bios. Also they offer 24 hr turn around on e-mail tech.

Details from

Model          Cyl     Hds SCT Wpcom Model
M1614TAU 2114 16     63   00          1091MB

Not very helpful. No PIO mode given
Try reducing the PIO mode or Turning off LBA mode.
LBA mode is only needed for translating the drive geometry to DOS or other operating systems that dont understand more than 1024 cylinders.
Windows 95 recognises large hard drives & doesn't need LBA mode.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.