• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 669
  • Last Modified:

Usage of /usr/bin/rmail

This is almost certainly a trivial question, but unfortunately my system doesn't have the manual pages for rmail. When I try the following command:

echo "localhost myname" | rmail myname

I expected mail to be posted back to myself. Instead, I got the message: "missing or empty From line". What format changes do I need to make?
0
ventnor
Asked:
ventnor
  • 3
  • 3
1 Solution
 
gracieCommented:
rmail is for recieving mail

echo "localhost myname" | mail myname

should do it.  you can add a "-s" to put a subject on it.

echo "localhost myname" | mail myname -s "It worked!"

Take Care,
Tracy Bryson

0
 
ventnorAuthor Commented:
Thanks for answering my question, but I won't grade it as yet. For a start, I'd be interested to know what the machine is expecting when it says "missing or empty From line". What would I have to add to the line I gave so that that message did not come up?

My second comment is that my system doesn't like the -s flag. It says "illegal option".

Thanks,

ventnor
0
 
gracieCommented:
what system are you on?
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
ventnorAuthor Commented:
Gracie,

I'm on Linux 2.0.0, Slakware distribution.

Thanks,


ventnor.
0
 
gracieCommented:
All of the research I have done on mail agree that -s is real.  Possibly, your sysadmin has tweaked things a bit.

As far as rmail, I'm not quit sure why you would want to use it.  Most of the URL's I found talked about using it with emacs (as a wrapper?).  Here are 2 good sites that I found:
http://mmg2.im.med.umich.edu/~kcheek/texi-docs/xemacs/rmail_2.html
http://sunland.gsfc.nasa.gov/info/emacs/Rmail_Reply.html

note that both have "emacs" in the path.

Have fun, and good luck!

~Tracy
0
 
ventnorAuthor Commented:
The Linux system is my own, so it hasn't been tweaked at all. I shan't grade this question, as it still hasn't really been answered.


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now