Solved

" .xinitrc file not found "

Posted on 1997-06-21
5
309 Views
Last Modified: 2013-12-06
I have installed Red Hat ver 4.0 and setup XF86Config using xf86config file as root writing it to /usr/X11R6/lib/X11.
I located .xinitrc in /usr/X11R6/lib/X11/xinit and located this in my PATH statement. When I execute 'startx' I get an error message :

   xinit: No such file or directory (errno 2): no server "X" in PATH

   xinit: Invalid argument (errno 22): unable to connect to server

   xinit: No such process (errno 3): Server error

 As I said, I have physically looked at .xinitrc inside xinit dir ...it's there and in the PATH statement....

Any ideas??  Thank You.


any suggestions?


I tried answer from jprohart but no luck.....
I did find out that I don't have an "X" dir under "bin".
If this is my problem, can I mount the CD I installed from and get that sub dir? I really don't understand how this got left out.... the installation was a straightforward prompt setup and asked to install 'X-Windows'.
0
Comment
Question by:ronalddd
  • 3
  • 2
5 Comments
 

Author Comment

by:ronalddd
ID: 1626406
Edited text of question
0
 
LVL 2

Accepted Solution

by:
jprohart earned 100 total points
ID: 1626407
it looks like your X server has no link to /usr/X11R6/bin/X
to be sure, run 'X -probeonly'. If it does not run, you must link your X server. Cd into /usr/X11R6/bin then do 'ln -s your_X_server X'.
if you use SVGA driver, 'ln -s XF86_SVGA X'
with S3, 'ln -s XF86_S3 X' and so for other servers.
bye
0
 

Author Comment

by:ronalddd
ID: 1626408
Edited text of question
0
 

Author Comment

by:ronalddd
ID: 1626409



               I tried answer from jprohart but no luck.....
               I did find out that I don't have an "X" dir under "bin".
               If this is my problem, can I mount the CD I installed
               from and get that sub dir? I really don't understand how
               this got left out.... the installation was a straightforward
               prompt setup and asked to install 'X-Windows
0
 
LVL 2

Expert Comment

by:jprohart
ID: 1626410
/usr/X11R6/bin/X is not a sub-dir but a link on your XFree server. Create it with the ln command. If you want more help, send your configuration and XF86Config . You can also download the 3.3 version of XFree and use XF86Setup to configure it (easy), it will create the link automatically. But it's better to do it work before.

0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now