Solved

Messed up FAT (16) after OSR2 install.

Posted on 1997-06-21
28
148 Views
Last Modified: 2013-12-16
null
0
Comment
Question by:superstarr
  • 10
  • 10
  • 4
  • +3
28 Comments
 

Author Comment

by:superstarr
ID: 1748924
It might be useful to know WHAT my BIOS is... It's PhoenixBIOS version 4.04 if that helps. Thanks.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748925
From dos prompt type FDISK /STATUS. See if it's using 100% of your HD. I'm sure you have your LBA on, yes?
0
 

Author Comment

by:superstarr
ID: 1748926
Yup. I even did a low level format with a program from Maxtor (hd maker) and set it to use LBA, tell FDISK to do so and made sure the CMOS was set to use it. I've tried with my HD at 100% and at 99% (515 and 512, respectively, as far as FDISK is concerned).
0
 
LVL 1

Expert Comment

by:compmech
ID: 1748927
I don't understand..if you used FDISK off the osr2 it would install a FAT32 allocation table not FAT16.
Are these the details listed in your CMOS
Cyl  heads  Sectors
1024   16     63
Your HArd disk should be set on Normal not LBA which is what I think Smeebud was saying.
Are you sure the Dos Partition is correctly setup?
Sorry to have to say you need to reformat accordingly and all should be well.

0
 

Author Comment

by:superstarr
ID: 1748935
Yup, partioned my 515 (max according to FDISK) as the primary (and only) logical drive. Thanks for keeping up on this.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748936
MAXTOR CORPORATION             800-2-MAXTOR 303-678-2700
Go to http://www.maxtor.com/ss.html.
in your original question you say,"1 Gig in size (when my HD is formatted to 512 - 515 max)". Then you say,"7540AZ (and FDISK says its maximum capacity is 515mb - I've been formatting with 511, which it rounds to 512)."
Are you sure your 7540az is large enough for I Gig?
I could'nt find it there at: http://www.maxtor.com/ss.html

0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748937
Here's another letter from a fellow newsgroup companion.
-----------------------------------
Sounds like one of those machines MS says OSR2 will not run on.

In addition, he needs to use LBA addressing for the disk if it is bigger than 504 MB.

He can just tell the CMOS  1024 cyl, 16 hds, 63 sectors for a 504 disk.
---------
I'm on the case. This one has my interest.
0
 

Author Comment

by:superstarr
ID: 1748938
No, when talking in reference to 1 gig, I'm saying 'dir' reports many > 1 Gig files, which of course, is hogwash. My hard drive maxes to 515 in FDISK.
0
 

Author Comment

by:superstarr
ID: 1748939
Also, I've called Maxtor and they sluffed it off as a software problem and gave me no help - told me to call Microsoft, which is the utter and last resort. My CMOS settings are correct, and I'm pretty sure the BIOS isn't too old at this point, but still looking for positive verification.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748940
Typical run around. There may not be anything on the Pheniox's site but I'm sure you can contact thier support. I'll go back a recheck but I'm pretty sure they offer 24hr turn around on questions. And usually e-tech is better than phone tech, they ain't got a clue. All you shoul;d have to do is provide them with the bios information that appears on your screen at boot-up.
Hit pause when you see this very large number and write it down.
That's the *only* way even their tech can determine anything about your bios. That number is date AND code that discribes your particular bios.
Now don't take this wrong,but if you have not done that, you can't eliminate the bios as a problem.
0
 

Author Comment

by:superstarr
ID: 1748941
On another note, I finally found out the date of my BIOS. It's 11/05/94, so it should be current enough. My version does implement LBA and something called int32, which should distinguish it from older BIOS that OSR2 doesn't like. That's all I've been able to gleam from Phoenix's web page. I have yet to call them, but I will.

On yet another note, I'm going to try install NT 4.0 Workstation and see if I have the same results tonight.
0
 
LVL 14

Accepted Solution

by:
smeebud earned 100 total points
ID: 1748942
You may have to extract fdisk or make it from the make startup disk option.
----------------
I think I might have a solution to your problem.  If you have
OSR/2, see if the setup disk they sent with the machine or software, has fdisk on it. I've been experimenting with Fat32 and found it to be vastly superior to non-fat32 systems. OSR/2 is supposed to work with both fat16 fat32. Use the fdisk program that came with the OS and see if you get a screen that asks you if you want to use fat32 or fat16. I suspect, without the driver for the hard drive, it wouldn't boot. Try fat32. OSR/2 said he
would work with fat16, but I've never tried it and once I did Fat32, a lot of stuff for fat16 was erased.
I don't know if this is the solution for you or not. But I'm hoping it will be something Non-labor involved.
=====
About bios, 1994, well in this industry, that quite old. I think I'd check that out. I'm sure I'd check that out.
0
 

Author Comment

by:superstarr
ID: 1748943
Well, that's the one thing the guy from Maxtor said, that BIOS from the latter half of 94 were safe. Now, of course, I shouldn't take his word for it, I'm still going to call Phoenix. Thanks.. I'll see what I can do later.
0
 

Author Comment

by:superstarr
ID: 1748944
Oh yeah, and I've got a boot disk from the osr2 CD, but the fdisk on it doesn't give me that 32/16 bit choice. The only thing it asks is to turn LBA on or off and what the size of my partitions is going to be.. in which case, how I can I try to extract from the CD, hoping that it will be a different fdisk?
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 14

Expert Comment

by:smeebud
ID: 1748945
If it came off the CD, it's not gonna be any different.
What options does your fdisk offer when from a real dos prompt you type FDISK/? .
This is really tough. I think I already suggested Partion magic.

0
 
LVL 1

Expert Comment

by:compmech
ID: 1748946
In OSR2, if you run the FDISK tool on a system with a drive over 512 MB, it asks whether to enable large disk support. If you
answer Yes, any partition you create that is larger than 512 MB is marked as a FAT32 partition.

0
 
LVL 1

Expert Comment

by:compmech
ID: 1748947
Anything below that size will automatically be FAT16
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748948
Well, compmech answered that one.
At Dos prompt type CHKDSK, it will show you one the first line exactly how big you HD is.
compmech,
How do you feel about my suggestion of using Partition Magic.
Glad you jumped in here.
0
 
LVL 1

Expert Comment

by:compmech
ID: 1748949
When I've tried with Partition Magic it still wouldn't work under 512MB. Bottom line FAT32 is Microsofts new base for big boys in hard drives talking up to 2 terabytes in size.In other words everything over that previous 1024cyl limit.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748950
superstarr,
See: http://www.maxtor.com/ide_cmos.html
Locate your HD and check your parameters.
http://www.maxtor.com/email.html
http://www.maxtor.com/faq_bios.html
http://www.maxtor.com/faq_bios.html#BIOS-Q1
http://www.maxtor.com/readme/dm.html
What happens when you try to install and don't fdisk. your patition should already be set.
I was looking for a Maxtor HD diagnostic at theit site.
See if you can find one.
It may be time to upgrade.
I know, $$$$
0
 

Author Comment

by:superstarr
ID: 1748951
Well, in the end, I've installed NT 4.0 Workstation, and by using NTFS, the problem of disk corruption has vanished. So, to that end, I'm now pretty sure it was the file system. So, smeebud's answer was in the right direction, but I wasn't able to install 95 in the end, which is AOK with me, because I'm loving NT better anyway. Thanks for all the help guys.

SS
0
 
LVL 4

Expert Comment

by:jetx
ID: 1748928
superstarr,

I have encountered this problem too, When ever I tried to load up my previous dos in OSR2, my FAT32 partition will be turned into FAT16, The only way to fix this is to delete the whole windows directory and reinstall the windows os.

note: delete all previous dos version.


regards,

jetx
0
 
LVL 3

Expert Comment

by:Ikon
ID: 1748929
It is not *possible* to boot your previous version of DOS once you use FAT32 therefore you must be using FAT16 all the time.
OSR2 will not automatically suggest FAT32 unless your HDD > 512MB.
It sounds like you may have a banjaxed HDD.
Try loading just DOS on it and see if you have probs then.
Run Norton diags in exaustive mode on the HDD (should take about 4 hours) and see what it says.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748930
You do not need LBA enabled, may be causing your problems.
I assume that you recieved a Boot disk with your OSR2  CDROM.
It should have on it FDISK.EXE AND SYS.COM.
If not, (If you do have OSR2 installed) make a Startup Disk)
------
Sometimes your system is unbootable. Create a bootable "rescue" floppy disk. Insert a good blank
disk. Select Start/Settings/Control Panel, double-click on the Add/Remove Programs icon. Click on
the Startup Disk tab then click on Create Disk. When Win95 is done, make the disk read-only, label
it and test it to be sure you can boot your computer from it.
Then, You must create an Autoexec.bat that reads:
A:\MSCDEX.EXE /D:MTMIDE01 /M:15 /E and copy the mscdex.exe on your disk. The MTM
part is mine for Mitsumi, you have to substitute your CD parameters.
1. The following is a simple AUTOEXEC.BAT File
@ECHO OFF
CLS
A:\MSCDEX.EXE /D:MTMIDE01 /M:15 /E
-------------------
You must create a Config.sys that reads:
DEVICE=A:\HIMEM.SYS
DEVICE=A:\EMM386.EXE
DEVICE=A:\MTM\MTMCDAI.SYS /D:MTMIDE0 [Substitute your CD parameters here.]
DOS=HIGH,UMB
FILES=30
BUFFERS=30
2. The following is My CONFIG.SYS File. Note that I'm using my Mitsumi CD-ROM Parameters.
-------------------
DEVICE=A:\HIMEM.SYS
DEVICE=A:\EMM386.EXE
DEVICE=A:\MTMCDAI.SYS (Your CD ROM Driver would go here)
-------------------
3. The following are the Files I have on my disk.
EDIT.COM, FORMAT.COM, REGEDIT.EXE, FDISK.EXE, SYS.COM, HIMEM.SYS,
EMM386.EXE MSCDEX.EXE, XCOPY.EXE, DELTREE.EXE, ATTRIB.EXE,
DISKCOPY.EXE, CHKDSK.EXE DEBUG.EXE, EMM386.EXE, MSCDEX.EXE,
SCANDISK.EXE, UNINSTALL.EXE
MTMCDIA.SYS (Your CD ROM Driver would go here)

Start from the Get go: No LBA and No fAT32.
0
 

Author Comment

by:superstarr
ID: 1748931
Already tried all of that, long time ago. I have that boot disk and have been able to do (and did) what you've suggested. It didn't help. Inevitably, when I'd finish the Win95 setup, the final reboot before I'm through would always lock and I'd break out to a command prompt (via the boot disk) and see that my C:\ drive was all messed up again.

No worries, I have long since moved to NT 4.0 and find life much better. Thanks for all the ideas, though.
0
 
LVL 3

Expert Comment

by:chapie
ID: 1748932
I had a strange encounter as well, not similiar but maybe the same solution could remedy the situation here.

If you're not using a 486 and already have a pentium running then I suppose this post won't help but I didn't see if that was specified before.

My 486/66 couldn't format above ~500MB, so most ppl say you must partition it, except my co-worker told me to bring it in and install it on the pentium here, and take it home it should work (not 100% sure depends on system), but it worked I took the HDD home and it's at 2.0 GB eventhough I could only partinion and format up to 500MB before, it till supports it.

Let me know if this tidbit helped any and I'll repost as an answer if it does....BTW if you don't have access to a pentium then your local retailer/repair shop should be willing to simply partition and format the drive for you for a very nominal fee.
0
 
LVL 4

Expert Comment

by:jetx
ID: 1748933
please delete this question.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1748934
Please if your not going to award any one points have this question removerd or it will hang around here forever.
-------
A Safe Method To Re-Install 95 and Save Vital Files

Reinstall win95 from the command prompt using (setup /p f ) command. That will clean your system
files and replace missing and damaged files, without over-writing your updated dll's vxd's ext.
f - This switch enables Clean Registry mode. It forces Detection to clean the root branch of the
registry before starting. This switch is ignored when Setup is run in the Windows 95 graphical user
interface (GUI). The default is disabled. Example: setup /p f
As Always: Backup Your Registry First!
NOTE: The Setup /p f command does remove some commands that are pointing to the wrong
locations of programs and Win95 files, also does remove commands that are unknown to Win95
from the System.ini, Win.ini and the registry, but no promises can be given due to the nature of
Win95's individuality. So ALWAYS backup your registry and system files first.
/d - If you do not want Setup to use your existing Windows configuration (such as your current
Win.ini and System.ini files), use this switch.To restore and adjust your windows installation try this:
From dos insert your CD and run from your cd this command...
(setup /d /p f) When setup prompts you for "Full or Custom Setup", choose Custom. This allows you
to have control over every step of the setup.
This will do a compare and replace missing or corrupted files and will take you back where you were
before the error.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Recently Microsoft released a brand new function called CONCAT. It's supposed to replace its predecessor CONCATENATE. But how does it work? And what's new? In this article, we take a closer look at all of this - we even included an exercise file for…
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now