How to delete entries in COMMUNICATOR history dropdown list?


I have installed communicator on my machine. I have already had Netscape Navigator version 3. After installation when I opened the history drop down list(the box at the top of the screen below the toolbar keys that shows the addresses of the sites), it showed the ten latest sites I had visited with Navigator 3. I want to delete these URLs and have a clean history list for a start.

Now, I already know how to delete the history list in Navigator 3, by going to registry
and work there. I thought maybe Communicator has access to the same file there, so I went there and cleaned it, but Communicator still showed the ten URLs. I searched the registry for any other file that might have that list, I could not find anything, at least under the communicator files in the registry. I deleted communicator and reinstalled it, it still shows those sites. What should I do?

1-Should I first delete the Navigator and then install the communicator? But it might still show the sites, if they are saved on another place on Registry or someplace else.

2-Is it possible that it looks into Cache or Netscape.hst files to create the history list?

Can anybody tell me where can I find the file that keeps these histories and how can I delete them?



PS. I love Netscape and prefer it to Microsoft Explorer, but why can't these guys come up with a clean utility like Microsoft Tweak for doing these small changes. And Microsoft people have not included anything for netscape history list in their Tweak.
Who is Participating?
dwenConnect With a Mentor Commented:
If you want to clean the information in the "Location" pulldown menu, this is you should do:
For Netscape Communicator(version 4.0),the file you should be looking for is a file named "prefs.js" under your user's directory, for example:
C:\Progarm Files\ Netscape\Users\Yourname\prefs.js

Exit from the Communicator.
Open the file by using the "Notepad" text editor.
You'll see several lines in the file like this:
user_pref("browser.url_history.URL_1", "");
user_pref("browser.url_history.URL_2", "");
Delete all of there lines(but not any other lines in the file),then save the change and start Communicator again. Now the "Location" menu should now be empty.

Remember: your browser should not be running while you make these changes!!

rf203Author Commented:

Thanks. I did what Dwen said and it was solved.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.