CreateKey error running REGINI under WinNT 4.0

I am logged onto NT Workstation 4.0 as Administrator, trying to use REGINI.  When I execute an .ini file which adds the key

\Registry\Machine\System\CurrentControlSet\Envm\Root\LEGACY_TEST\0000

I get a "CreateKey" error.  How do I resolve this?
dpangAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

md041797Commented:
You must start your key with either HKEY_LOCAL_MACHINE or HKEY_USERS. Try HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Envm\Root\LEGACY_TEST\0000


0
dpangAuthor Commented:
Answer incorrect.  Branch in registry protected and cannot be modified.
0
NickRepinCommented:
I've tried to run regini.exe on my Windows NT 4.0 Server:

   regini aaa.ini

There was a single line
   \Registry\Machine\System\CurrentControlSet\Envm\Root\LEGACY_TEST\0000

in the aaa.ini file.

All worked fine! The key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Envm\Root\LEGACY_TEST\0000 was created!

So it must work without any problem.

Are you sure the 'administrator' user is in 'administrators' group?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NickRepinCommented:
You may fail to create a key if you don't have enough rights (regini reports error code -5).
Run regedit32, go to CurrentControlSet key, invoke menu Security->Permissions and make sure Administrators group has a full control rights.
0
dpangAuthor Commented:
Just noticed that there was a typo in my question!  "Envm" should be "Enum".  But anyway, your comment answered the question!

On the grading page there is an option to "Mark a comment as an answer...", but following this link gives the error "The requested URL /topics/bin/ChooseAnswer was not found on this server."

Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.