Solved

Prevent 95 to save the profile on local disk

Posted on 1997-06-24
11
324 Views
Last Modified: 2013-12-23
This was the q, but I've solved it.

I have a problem concerning win95´s ability to handle individual settings for multiple users. In school I have 450 different users who logs in to different workstation all over the place. I want win95 only to read the user.dat-file from the home directory and not to store it locally. Otherwise i soon will have lots of different users on every single workstation.
Another problem concerning this matter is that I use a program that write-protects the disk so it wont work anyway.
I also want to get rid of the message "You haven´t logged in to this workstation before - do you want to use individual setting?" (or something like this - a very free translation from swedish) Is this possible? And if it is - how?

Very thankful for any help.
0
Comment
Question by:rille062497
  • 5
  • 5
11 Comments
 
LVL 1

Expert Comment

by:Technocrat062397
ID: 1545645
Windows 95 Can NOT do this.  Your awnser is to setup an NT server  
store all the profiles there (this is easy to do) Make everyone log onto the server.  The profiles will be downloaded when they login.
0
 

Author Comment

by:rille062497
ID: 1545646
I allready have an NT-server and that part is working just fine.
Perhaps I was a bit unclear in my q, I want win95 ONLY to load the profile from the homedirektory. In this way I hopefully would get rid of that message at startup.
Or, perhaps you mean that all profiles should be stored in one separate directory on the server. Can I make win95 to look for profiles on a network share? If this is possible, that could be a solution for me but how can i tell win95 to look for profiles in a network share?
0
 
LVL 3

Expert Comment

by:Ikon
ID: 1545647
It can be done on both Novell & NT servers, the primary logon has to be set to the server you are using & the following must also be in place...
For NT from http://www.microsoft.com/kb
How to Save User Profiles on a Microsoft Windows NT Server

Last reviewed: April 17, 1996
Article ID: Q138046 The information in this article applies to:

•Microsoft Windows 95







SYMPTOMS

You may be unable to save user profiles to a Microsoft Windows NT server.





CAUSE

This problem can occur if the following conditions exist:

•The Primary Network Login setting is not set to Client For Microsoft Networks. •User profiles are not enabled. •A Home directory is not set up correctly for the user on the domain.







RESOLUTION

To resolve the problem, follow these steps:



1.Set the Primary Network Login setting to Client For Microsoft Networks.

2.Enable user profiles.

3.Set up a Home directory on the Windows NT server. To verify that the Home directory is set up correctly, type the following line at an MS-DOS prompt





      net use <x>: /home





where <x> is a drive letter.

If you receive an error message stating "The syntax is incorrect," Home directories are not set up correctly.

For additional information about setting up Home directories, please see the following article in the Microsoft Knowledge Base:





      ARTICLE-ID: Q137979

      TITLE     : Creating Windows 95 Home Directories on Windows NT
                  Server
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:rille062497
ID: 1545648
Thanks for the help gyes, but I've solved the problem today.
Here is how I did it!

First, I use kixtart to emulate lmscript.exe. If you dont known this take a look at:
http://netnet.net/~swilson/kix.html

This is the script (with comments, starts with ";")

;#####################################################
;# Login script for standarusers at Osterholmsskolan #
;# in order to use individual settings for the users #
;#             Made by Richard Sjögårdh              #
;#      richard@osterholmsskolan.stockholm.se        #
;#####################################################

use h: /del            ;to delete previous individual shares
use o: /del            ;to delete previous individual shares
use y: /del            ;to delete previous individual shares
use h: @homeshr      ;to assign home dir
if @error =0
h:
cd @home dir
use p: \\eastsrv\program          ; to assign programs
use q: \\cd_torn\cd              ; assign cd-tower
use r: \\eastsrv\focuscd
use u: \\eastsrv\focus97      ; to assign Focus97directory
use v: \\cd_torn\dkmmscie      ; to assign Vetenskapscd
use w: \\cd_torn\dkmmhist      ; to assign Historiascd

If exist ( h:\user.dat );to check if the user all ready have
                  ;the individual stuff in the home dir             
goto goon
       
Else       ;If the user never used the network he
      ;needs the stuff i his home dir so it will
      ;be copied there. He receives some default stuff.      

run "c:\windows\command\xcopy32 p:\profiles\elev\*.* h:\ /k /e /q /h" ;(elev=student in swedish)

:goon

;Now I del. the profile list in the registry.
;In this way I wont get that huge registry-file.

Deltree("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProfileList")

;But I have to add a individual key for the user that
;logs on, otherwise the message will turn up.

Addkey("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProfileList\@userid")

;Then I sets the profileImagePath to h:\ (home dir).
;In this way no Profiles are created locally!

WriteValue("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProfileList\@userid","ProfileImagePath","h:\","REG_SZ")

;Then some other stuff that doesnt concerns the topic.

settime eastsrv
cookie1
use list

exit

This is my solutions to the problem, and it work so far, in august, when all my students are back I will be able to test it properly. Today I've tested it in several different situations and it didnt return any errors.


0
 

Author Comment

by:rille062497
ID: 1545649
Edited text of question
0
 
LVL 3

Expert Comment

by:Ikon
ID: 1545650
My answer was correct, please award my points dont swizz me or I won't answer any more of your questions.
0
 

Author Comment

by:rille062497
ID: 1545651
Hi Ikon!
I'm sorry to say that I dont agree with you. My homedirectorires are working fine. My problem was to force win95 NOT to save the profiles locally and to get rid of the message for new users after logon. Your answer dont match any of them.
Please dont whrite anything more in this question, otherwise, this question will not be deleted. You are welcome to contact me at work.
webmaster@osterholmsskolan.stockholm.se
0
 

Author Comment

by:rille062497
ID: 1545652
Hi Ikon!
I'm sorry to say that I dont agree with you. My homedirectorires are working fine. My problem was to force win95 NOT to save the profiles locally and to get rid of the message for new users after logon. Your answer dont match any of them.
Please dont whrite anything more in this question, otherwise, this question will not be deleted. You are welcome to contact me at work.
webmaster@osterholmsskolan.stockholm.se
0
 
LVL 3

Expert Comment

by:Ikon
ID: 1545653
Try this one...
How to Save User Profiles on a Microsoft Windows NT Server

Last reviewed: April 17, 1996
Article ID: Q138046 The information in this article applies to:

•Microsoft Windows 95







SYMPTOMS

You may be unable to save user profiles to a Microsoft Windows NT server.





CAUSE

This problem can occur if the following conditions exist:

•The Primary Network Login setting is not set to Client For Microsoft Networks. •User profiles are not enabled. •A Home directory is not set up correctly for the user on the domain.







RESOLUTION

To resolve the problem, follow these steps:



1.Set the Primary Network Login setting to Client For Microsoft Networks.

2.Enable user profiles.

3.Set up a Home directory on the Windows NT server. To verify that the Home directory is set up correctly, type the following line at an MS-DOS prompt





      net use <x>: /home





where <x> is a drive letter.

If you receive an error message stating "The syntax is incorrect," Home directories are not set up correctly.

For additional information about setting up Home directories, please see the following article in the Microsoft Knowledge Base:
__________________________________________________
Creating Windows 95 Home Directories on Windows NT Server

Last reviewed: May 8, 1997
Article ID: Q137979 3.50 3.51 95 WINDOWS kbinterop

The information in this article applies to:

•Microsoft Windows NT Server versions 3.5 and 3.51 •Microsoft Windows 95







SYMPTOM

Your Windows 95 clients cannot connect to their home directories even though you create a profile in Windows NT User Manager that specifies the Windows 95 users' home directory and drive letter to use for the connection.





CAUSE

Windows NT is not properly configured or your script is incorrect.





RESOLUTION

To allow Windows 95 users to connect to their home directories on the server, create a logon script to connect a Windows 95 client to a home directory and configure your Windows NT Primary Domain Controller (PDC) as follows:



1.Create a test logon script on the Windows NT PDC for Windows 95 client workstations:

echo on net use * /HOME pause

2.Place the script file in the SYSTEM32\REPL\IMPORT\SCRIPTS directory on the Windows NT PDC. (You may also want to set up File Replication so the logon scripts you create are available on all domain controllers.)

3.Make sure that the test user logging on has Full control of the \SCRIPTS directory and at least Read permission on the Netlogon share (the default share of \WINNT35\SYSTEM32\REPL\IMPORT\SCRIPTS).

4.Create a subdirectory called TEST in the shared Users directory. By default the shared Users directory is C:\USERS.



5.Share the Test subdirectory with the share name TEST and give the test user 'Full Control' permission to the share. 6. Run User Manager for Domains and select the user for the test.



6.From the User menu, choose Properties.

7.Choose Profile in the User Properties dialog box.

8.Type the test logon script name in the Logon Script Name field.

9.Under Home Directory, in the To field type:

\\<server_name>\TEST

NOTE: Ignore the drive letter in the Connect field.

10.Log on as the test user at the Windows 95 client.

The following text appears at the command prompt:

c:\win95>echo on c:\win95>net use * /home d: connected to \\<servername>\TEST c:\win95> pause Press any key to continue. . .

11.On the Windows 95 client, press any key to continue. Then doubleclick the My Computer icon.

NOTE: In My Computer, the home directory maps to D: (or the next available drive letter on the client).

12.If the logon script executes correctly, you may delete the Echo On and Pause lines from your script resulting in your script consisting of only the following line:

net use * /HOME

NOTE: You may specify a drive letter in place of the Next Available Drive symbol, the star (*). You may also rename the Users\Test directory to any name; be sure to make the corresponding changes wherever this new directory name is used.







MORE INFORMATION





Using NET USE * /HOME from Multiple MS-DOS Command Prompts

If you use the NET USE * /HOME command from more than one MS-DOS command prompt in Windows 95, your current directory is going to be set incorrectly. Your current directory is going to be the root of the server containing your home directory instead of your default home directory.
0
 
LVL 3

Accepted Solution

by:
Ikon earned 150 total points
ID: 1545654
Try this one...
How to Save User Profiles on a Microsoft Windows NT Server

Last reviewed: April 17, 1996
Article ID: Q138046 The information in this article applies to:

•Microsoft Windows 95







SYMPTOMS

You may be unable to save user profiles to a Microsoft Windows NT server.





CAUSE

This problem can occur if the following conditions exist:

•The Primary Network Login setting is not set to Client For Microsoft Networks. •User profiles are not enabled. •A Home directory is not set up correctly for the user on the domain.







RESOLUTION

To resolve the problem, follow these steps:



1.Set the Primary Network Login setting to Client For Microsoft Networks.

2.Enable user profiles.

3.Set up a Home directory on the Windows NT server. To verify that the Home directory is set up correctly, type the following line at an MS-DOS prompt





      net use <x>: /home





where <x> is a drive letter.

If you receive an error message stating "The syntax is incorrect," Home directories are not set up correctly.

For additional information about setting up Home directories, please see the following article in the Microsoft Knowledge Base:
__________________________________________________
Creating Windows 95 Home Directories on Windows NT Server

Last reviewed: May 8, 1997
Article ID: Q137979 3.50 3.51 95 WINDOWS kbinterop

The information in this article applies to:

•Microsoft Windows NT Server versions 3.5 and 3.51 •Microsoft Windows 95







SYMPTOM

Your Windows 95 clients cannot connect to their home directories even though you create a profile in Windows NT User Manager that specifies the Windows 95 users' home directory and drive letter to use for the connection.





CAUSE

Windows NT is not properly configured or your script is incorrect.





RESOLUTION

To allow Windows 95 users to connect to their home directories on the server, create a logon script to connect a Windows 95 client to a home directory and configure your Windows NT Primary Domain Controller (PDC) as follows:



1.Create a test logon script on the Windows NT PDC for Windows 95 client workstations:

echo on net use * /HOME pause

2.Place the script file in the SYSTEM32\REPL\IMPORT\SCRIPTS directory on the Windows NT PDC. (You may also want to set up File Replication so the logon scripts you create are available on all domain controllers.)

3.Make sure that the test user logging on has Full control of the \SCRIPTS directory and at least Read permission on the Netlogon share (the default share of \WINNT35\SYSTEM32\REPL\IMPORT\SCRIPTS).

4.Create a subdirectory called TEST in the shared Users directory. By default the shared Users directory is C:\USERS.



5.Share the Test subdirectory with the share name TEST and give the test user 'Full Control' permission to the share. 6. Run User Manager for Domains and select the user for the test.



6.From the User menu, choose Properties.

7.Choose Profile in the User Properties dialog box.

8.Type the test logon script name in the Logon Script Name field.

9.Under Home Directory, in the To field type:

\\<server_name>\TEST

NOTE: Ignore the drive letter in the Connect field.

10.Log on as the test user at the Windows 95 client.

The following text appears at the command prompt:

c:\win95>echo on c:\win95>net use * /home d: connected to \\<servername>\TEST c:\win95> pause Press any key to continue. . .

11.On the Windows 95 client, press any key to continue. Then doubleclick the My Computer icon.

NOTE: In My Computer, the home directory maps to D: (or the next available drive letter on the client).

12.If the logon script executes correctly, you may delete the Echo On and Pause lines from your script resulting in your script consisting of only the following line:

net use * /HOME

NOTE: You may specify a drive letter in place of the Next Available Drive symbol, the star (*). You may also rename the Users\Test directory to any name; be sure to make the corresponding changes wherever this new directory name is used.







MORE INFORMATION





Using NET USE * /HOME from Multiple MS-DOS Command Prompts

If you use the NET USE * /HOME command from more than one MS-DOS command prompt in Windows 95, your current directory is going to be set incorrectly. Your current directory is going to be the root of the server containing your home directory instead of your default home directory.
0
 
LVL 3

Expert Comment

by:Ikon
ID: 1545655
Sorry about the duplication.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A brief overview to explain gateways, default gateways and static routes OR NO - you CANNOT have two default gateways on the same server, PC or other Windows-based network device. In simple terms a gateway is formed when a computer such as a serv…
Enterprise networks where VoIP phones have been deployed frequently use port configurations that allow both a computer and an IP phone to be plugged into the same switch port but use different VLANs. On Cisco equipment I'm referring to the "native V…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question