Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 377
  • Last Modified:

color depth in X

I've installed RedHat 4.2.  i'm having trouble setting right color depth.  i have Matrox Millenium with 4Mb of mem.  and i'm using 1280 x 1024 resoultion.  and it only displays in color depth of 8 bit.  there are 16bit and 32 bit subsection in  monitor section.  but seems like every time i try it only uses 8bit option.  i've try deleting 8bit subsection from XF86Config file but then it won't start x-server.  any help will be greatly appreciated.
thanks.
0
jcbz
Asked:
jcbz
1 Solution
 
jprohartCommented:
run 'startx -- -bpp 16' or 'startx -- -bpp 24' to run in 65536 or 16.7M colors.
If you want to always use 16 or 24 bits colors, edit /usr/X11R6/bin/xinit, and put '-bpp 16' or '-bpp 24' in the serverargs entry.Don't remove 8 bits section in XF86Config.
bye.
0
 
ahoffmannCommented:
check for
      DefaultColorDepth
in the Screen section in your XF86Config file, may be set to 8.

Ciao
Achim
0
 
sauronCommented:
Newer version of XF86 support a DefaultColorDepth keyword in the screen section of your XF86Config. Personally, I think this is the neatest way of setting it up.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now