pppd+mgetty and shadow and pam=problems

OK, I have +pap, -chap, I do everything like they write... But this doesn't work! Everyone can do ppp from Windows to my Linux box (with pap-secrets like "" * "")or nobody can do it! I have shadow (ppd was compiled with HAS_SHADOW) and pam pam-0.55-10. I need a help.
atuniaAsked:
Who is Participating?
 
cedricConnect With a Mentor Commented:
Hy,
Well, just try this one in your /usr/local/etc/mgetty+sendfax/login.conf

/AutoPPP/ -     a_ppp   /usr/sbin/pppd -chap +pap login -detach modem crtscts lock 192.168.0.2:192.168.0.3 proxyarp

Don't forget to remove the 'auth' option...
here it works very nice with a similar config as yours.
best regards....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.