?
Solved

Headless Server

Posted on 1997-06-27
9
Medium Priority
?
221 Views
Last Modified: 2013-12-16
Sparc works well as a headless server but how do I boot up without a keyboard attached.
Produces a "no keyboard" error followed by "boot device...  etc" and then a spinning cursor....I need it to run with no monitor and no keybd. So I can use it at home for research.
0
Comment
Question by:rickyr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
9 Comments
 
LVL 3

Author Comment

by:rickyr
ID: 1812463
Adjusted points to 200
0
 
LVL 3

Author Comment

by:rickyr
ID: 1812464
Edited text of question
0
 
LVL 3

Author Comment

by:rickyr
ID: 1812465
Edited text of question
0
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

 
LVL 3

Author Comment

by:rickyr
ID: 1812466
It used to boot ok with no keyboard. but I've done a few re-installs since then and now the problems has only recently appeared..

My thanks for reading this and gratitude if you can help
0
 

Expert Comment

by:vkg063097
ID: 1812467
Ok, It seems that you have only monitor attached to your sparc machine but no keyboard. In that case on power on sparc machine will give one message that no keyboard found and after that nothing will appear on console monitor. If you have setup the
boot environ ment (in NVRAM) for autoboot then your sparc will boot up automatically.
If you have one more machine that can run the serial terminal session then you can use that as serial console to this sparc machine. For this just connect the serial cable to sparc's serial port A and set up the parameter as setup in NVRAM of sparc. Use printenv to see all the options. On serial console you will see a lot of POST messages that you may not have seen on console monitor.
Check and modify following in your NVRAM
input-device
output-device
ttya-mode
ttyb-mode
0
 
LVL 3

Author Comment

by:rickyr
ID: 1812468
Hi vkg...so glad someone replied at last....
I've already  set input and output-device to ttya and used a psion on the serial port. "booting [DEVICE] with args:" then I get the banner. then its spinning cursor time.to get acces back again I have to disconnect the drive to get an OK prompt on the psion then reset the varibles.
The psion works fine as a terminal in normal conditions. The sparc is for home use (no deskspace)so an extra  terminal and monitor are not an option, I don't want a keyboard for the same reason. Now this used to work without a keyboard. the only thing I can think of is that this install is not the entire distribution but an end user cluster. Surely this cant be it. Can you have a re-think? I really want you to have the 200 points. Thanks again..........Ricky.
0
 
LVL 2

Expert Comment

by:gormenghast
ID: 1812469
The problem may well lie with the system installation only being an end-user cluster.
I had access to an old IPX that was not being used, so I networked it and did a re-install on this and installed the entire distribution cluster of Solaris 2.5.
After installation I added a couple of users then re-booted without a keyboard attached.
A message was output to the monitor "No Keyboard Found - using tty for input & output". Then the monitor turned black.
Gave the IPX time to finish booting. I was then able to telnet to the IPX from another sparc or a Macintosh.
It looks like it could be worth trying a re-install........Hope you have the same results I did.
0
 
LVL 3

Author Comment

by:rickyr
ID: 1812470
I did what Gormenghast said and it worked......
Present it as an answer and you can have the points.

GORMENGHAST ONLY

It was a bit drastic though I had to do a complete dump of the system then re-install then restore, took the best part of a day.
I hope I wont have to do that again too soon.
0
 
LVL 2

Accepted Solution

by:
gormenghast earned 200 total points
ID: 1812471
Glad it worked out OK rickyr......

Seems the problem was due to the installation cluster.

Thanks for the reply
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
My previous tech tip, Installing the Solaris OS From the Flash Archive On a Tape (http://www.experts-exchange.com/articles/OS/Unix/Solaris/Installing-the-Solaris-OS-From-the-Flash-Archive-on-a-Tape.html), discussed installing the Solaris Operating S…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses
Course of the Month14 days, 13 hours left to enroll

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question