Help: Problems with Call-back Protocol

I have an unusual problem that I hope someone can help me with. I'm trying
to configure FreePPP (2.5v2) to dial-in to two different servers. I have
been dialling in to a university UNIX server for several years without any
problems, but now I am trying to set up a second, faster line to a
Sun-based server at my place of work. The problem is that the new one
operates on call-back protocol. This means that I have to use the modem
initialisation string (for my SupraExpress 33.6) AT &F1 &C S0=1. The &F1 of
course is to set the default settings. The &C is to set the carrier detect
output value to ON at all times, regardless of the actual carrier
condition. This prevents the PPP software from aborting the connection
while it is waiting for the remote server to call back. Finally, the S0=1
(that's a zero, not an O) tells the modem to answer incoming calls after
one ring. (The default is 0, or not to answer at all.)

I have two problems. First, after disconnecting, I have to reset the modem
to its default settings or the next person who phones my house gets the
glorious modem squeal in the ear. (I can't simply turn off my modem as
there's no switch.) This is not a big problem. I've written a QuickKeys
sequence to open Smartcom and send the appropriate AT command upon
disconnecting. It just means that I have to disconnect from the QuickKeys
toolbar only, and never from the FreePPP menu. A far bigger problem, and
one I haven't figured out yet how to solve, is that I can no longer
disconnect from my former server, which I still use for news (such as now)
and for various other reasons. Since FreePPP has only one init string for
all accounts, it sends the same string when dialling in to the non-callback
server. When I disconnect, the carrier remains open because of the &C
command, and only restarting my computer seems to get it to hand up.

I'm really stumped on this. I've thought of trying to send a command to my
modem upon connecting, but can't figure out how to do that. I've read in my
manual that typing +++ while online will set the modem to command mode, but
it doesn't work. And opening Smartcom and sending a command after
connecting doesn't work either. Obviously, I would like a solution that is
as simple and quick as possible, since I dial in to both servers several
times a day.

Any help with this dilemma would be greatly appreciated.

With thanks, in advance.
bushellkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NyarCommented:
I have a possible answer, but it depends on you having Open Transport (since you didn't mention, and FreePPP will handle either...) (In any case, I strongly suggest you acquire OT unless you lack an '040 or better.  Much easier to mantain, much faster, much better.)

Grab a copy of OT/PPP.  It sets up several diffent setting, not unlike NCSA Telnet's Sessions option.  Unless I'm mistaken, one of the options for each setting is a modem setup string, which can be different for each setup.  (It may also be possible to have a after-session string, but about that I'm uncertain.)  Anyway, it was my experience that OT/PPP was faster, more reliable, and overall better than FreePPP (apart from lacking a menu for on/off.  However, for $25 you can get ColorSwitch Pro which, amongst other things, provides that functionality.)

Hope this helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bushellkAuthor Commented:
I found Nyar's answer acceptable, but unfortunately, I encountered a scripting error using  OT/PPP Setup and was unable to use OT/PPP. (I have all the required software mentioned, so it's a mystery why there was a problem.) I have since discovered that the latest version of FreePPP (2.6b4) allows for different initialisation strings to be sent to individual accounts. This has solved my problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.