Solved

VREDIR.VXD Problem

Posted on 1997-06-29
12
333 Views
Last Modified: 2013-12-16
I have been attempting to network the following two machines with only partial success.
I'm out of ideas......H E L P.....

Machine A:
486DX66 Clone, 16M, WIN95
LINKSYS 16 Bit Ethernet card using 10BaseT connection.

Machine B: (My New COMPAQ)
Compaq Presario (P120, 16M), WIN95
LINKSYS 16 Bit Ethernet card using 10BaseT connection.

Here is what works:
a) From machine A, I can access all shared drives on machine B.
b) From machine A, I can capture the printer on machine B, and print OK.
c) Descent2 runs IPX/SPX network games between the two machines.


Here is is what's driving me crazy!!!!!
-------------------------------------------------------
About 9 out of ten times, when attempting to access a shared drive on
machine a from machine b,
the redirector (VREDIR.VXD) rewards me with the blue screen of death.

(exception 0D in VREDIR.VXD...followed by the usual register dump,
Etc....).

At this point the system is toast!!!

NOTES:
1) There are no IRQ, DMA, or PORT ADDRESS conflicts.
2) I have tried removing all other network software and starting from scratch.
3)
0
Comment
Question by:fossey
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +3
12 Comments
 

Expert Comment

by:hezekiah
ID: 1749106
Does this only happen on machine A or does it also happen on machine B?

You might want to try hitting Ctrl-Alt-Delete once and remove everything except for things like Explorer, Systray, Rundll, and Em_exec (that's from my computer - I have a compaq presario as well)
0
 

Expert Comment

by:Keybounce
ID: 1749107
1. Have you verified that the network settings between the two systems are identical?

2. Does it matter which of the two machines playing descent starts the game and which one joins the existing game?

3. Have you tried any other games?

4. Have you tried any other network access, other than Descent and file sharing?

5. I'm assuming that you are using Microsoft networking on both machines (Client for microsoft networking is the primary logon, and file and printer sharing for microsoft networks is listed on both network control panel), and no trace of netware networking (not listed in either network control panel)
0
 

Expert Comment

by:hezekiah
ID: 1749108
Also, you might want to try re-installing the VREDIR.VXD driver. It could be corrupted. Slim chance, but it might work.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:fossey
ID: 1749109
I have tried three different versions of VREDIR.VXD:
1) The original one shipped with Win95.
2) The updated one shipped with service pack 1.
3) A patched version which was supposed to solve a buffering
problem between Win95 and Win NT.

I appreciate your attempt at an answer. Thanks.

0
 
LVL 3

Expert Comment

by:Ikon
ID: 1749110
I have come across similar problems with network cards and found it was cause by memory range conflicts.
Seriously, not on the local machines but across the networks (dont ask how). Changing the memory range on one of the cards solved the problem. (eg C0000-D0000 changed to E0000-F0000)
If this fixes it, let me know & I will re-submit as an answer.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1749111
Are you trying to used SHARE.EXE ?
0
 

Author Comment

by:fossey
ID: 1749112
Re: Comment from Ikon
There are no settings on the LinkSys Ether16 LAN Card for
memory.

Re: Comment from smeebud
No I don't think I'm using share.exe
I do the following: (1) Double click on Notwork neighborhood.
(2) Double click on a shared drive from the other machine.
(3) Watch my system crash!

0
 
LVL 3

Expert Comment

by:Ikon
ID: 1749113
If you put EmmExclude=A000-FFFF in the [386Enh] section of your system.ini on both machines what happens??

Have you got any different network cards you can try (all you need is probably one).
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1749114
fossey
read the share.exe relationship. Sometimes you have to trick you system because certain *hardware* sharing requires share.exe but 95 does not lile it. See if this mertod would apply.
-------------------------------

Well the guy has two choices.
1- If he has version 950 of windows 95, OS2 will
run the network program under windows 95. He needs
to install the  program from setup in
windows 95 and make sure that no network is
installed or running. After the installation check
Autoexec.bat for added share. if not there add
the following : to the bat file @C:\windows\command\share.exe.
Before verify, that a share.exe file exist under
that directory.
That should be enough for it to work, if not you need
the error messages.
2.He can install two differents setup on his computer.
A-Create a new partition on the hard drive "Fdisk".
B-Install Dos and Win 3.1 on that partition.
C-modify autoexec.bat to load either windows 95 setup
or win31.
Type Help under Dos command for Info on how to modify
autoexec.bat for several different setup or how to use
Fdisk.
Once this is done. Install the netware on the new partition.
That should make the system run it without problem.
He is going to have to provide more informations about the
netware he is using, the cards and the version of windows
95. And also on the systems that are already on the
system, I assumed that they at least run win 3.1.

0
 
LVL 14

Expert Comment

by:smeebud
ID: 1749115
sorry, I didn't mean to mark that as an answer. But pleas read anyway
0
 
LVL 1

Expert Comment

by:kevinb062397
ID: 1749116
From the MS Knowledge Base:
13 (0Dh): General Protection Fault

  Any condition which is not covered by any of the other processor exceptions will result in a general protection fault. The exception indicates that this program has been corrupted in memory usually resulting in immediate termination of the application.

There is another program that is stepping on the memory that is allocated for the VREDIR.VXD.  If you have already reinstalled the network (overwritting the files) then look for other things in your config.sys autoexec.bat system.ini registry and windows directories that could be different.

I had a similar problem opening *.doc files from a NFS drive it turned out to be an error in the NFS software.

Just FYI

From the MS Knowledge Base:
13 (0Dh): General Protection Fault

  Any condition which is not covered by any of the other processor exceptions will result in a general protection fault. The exception indicates that this program has been corrupted in memory usually resulting in immediate termination of the application.

0
 
LVL 14

Accepted Solution

by:
smeebud earned 100 total points
ID: 1749117
fossey,
please read this and see the articles that it refers to, they will tell you much about your problem.
Get back to me if you don't understand anything.
We'll put this VREDIR.VXD issue away for good.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Power Action 2 38
email content show up in iphone and ipad but not on windows 7 45
global cyber attack of may 2017 2 52
Windows 7 Pro WSUS updates not working 14 40
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
No single Antivirus application (despite claims by manufacturers) will catch or protect you from all Virus / Malware or Spyware threats. That doesn't stop you from further protecting yourself however - and this article is to show you how.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question