Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 333
  • Last Modified:

I can't receive mail

I have installed my slackware with  kernel 2.0.30 (I compiled it). My linux is conected directly to internet, I can telnet it from anywhere, I can ftp it, I can sends mail outside, etc. However, I can't receive mail from anywhere, but I can receive mail into the computer (among my users).
Any ideas?.
0
alacosta
Asked:
alacosta
  • 4
  • 3
1 Solution
 
sauronCommented:
You haven't provided enough information for an intelligent answer.

What MTA are you running? Sendmail? something else??
What MUA are you using?
Do you send outbound mail to a smarthost at your ISP?

A good place to start -  from your linux box run:-

host -t mx my.domain.com

Obviously substitute your domain name. This will show you what machines are Mail exchangers for you. Find the one with the lowest priority number, and then try to telnet to it on port 25.

Do you get a greeting message? Is the specified name your own machine? If you get no response on port 25, you ain't  running an SMTP server. You need to configure your MTA properly. If you're using sendmail, and the dafult config isn't right for you, you've got some work ahead. Going through the entire contents of your sendmail.cf file would take a bit long over Experts Exchange :-)
0
 
alacostaAuthor Commented:
Hello, Thanks for be interesting in my trouble, really I don't know with MTA I'm running I think it's sendmail because I have in my /etc a file called sendmail.cf, an I wrong?
I don't know what is MUA.

I ran the command host -t mx caracas.c-com.net and I got two answers first with the lowest priority (10) the caracas mail server and second the houston mail server(20), I tried to telnet mail.caracas.c-com.net on port 25 and there was not my name machine, however it was not a normal telnet.

Thanks again, any other question please fell free to ask.
P.D. My domain name is caracas.c-com.net
 
0
 
alacostaAuthor Commented:
I got answer when I telnet caracas.c-com.net on port 25
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
xtermCommented:
Sounds like you simply need to tell sendmail to answer for
your domain name (put domain aliases in /etc/sendmail.cw and
reference that file in /etc/sendmail.cf with a line like:
Fw/etc/sendmail.cw)  You do have a valid hostname, right ?(ie.
somebody is running DNS/MX for it...)

....because afaik, sendmail won't listen for user@numerical.addy
0
 
alacostaAuthor Commented:
Hello xterm, I have not /etc/sendmail.cw, do I have to create it? I'm not sure  I think I have a valid host name, I belong to the domain caracas.c-com.net  and I my computer's name is soporte, so I guess my computer is soporte.caracas.c-com.net. In addition, I have tried to send mail to it using for i.e root@204.95.128.25 and it still without receiving mail.

Thanks.
0
 
xtermCommented:
I figured that was the problem - You can't receive mail at
a numerical IP, but if you have a static, your ISP shouldn't
have a problem with adding a mail exchanger record & zone
file entry for your host.

Call them up and ask them to add soporte.caracas.c-com.net
to their DNS.

Add a line to /etc/sendmail.cf like this:
Fw/etc/sendmail.cw

Then just create /etc/sendmail.cw in a text editor with
the following line in it:

soporte.caracas.c-com.net

Then do:  ps -ax | grep sendmail (to find it's process ID)
then:     kill (process ID of sendmail)
finally:  sendmail -bd (to restart sendmail)

Then it should work fine :)

Oh, if you have a dynamic IP (ie. you don't get 204.95.128.25
every time you dial up your Internet Service Provider),
unfortunately you may be out of luck - read the mini-howto
entitled Dynamic-IP-Hacks available on sunsite.unc.edu to
find workarounds...)
0
 
alacostaAuthor Commented:
Hello xterm, I'm sorry for the delay. Your answer was very complete and I learned a lot, but I have an static IP address, my computer is connected 24 Hours to Internet (not always with linux). I did everything what you said but didn't work, in addition I ran netconfig (I have slackware) to see if it could help and didn't work, also, I installed my N serie again, and still without work.
Also I did
I just create /etc/sendmail.cw in a text editor with
the following line in it:

204.95.128.25
and with soporte.caracas.c-com.net (both times I reset my computer)
and nothing good happened

Thanks again.
0
 
xtermCommented:
As I told you before, you cannot receive mail at a numeric IP

Your Internet Service Provider MUST add an entry to DNS so
that if anybody in the world pings soporte.caracas.c-com.net,
it will say "Pinging 204.95.128.25 ...."

Do you understand?
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now