We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

NT4 file sharing problem.

Shaley
Shaley asked
on
Medium Priority
207 Views
Last Modified: 2013-12-14
I have setup a copy of the Administrator login but it will not allow me to share directories or files.  In Explorer the share option is not available.  I've looked at all the obvious stuff such as the checking the Server process is running and all the permissions, etc. and all seems OK.  I have recently re-installed NT4 due to a disk failure and previously I could share directories, etc. without any problems.

Any ideas
Comment
Watch Question

Is this account you are using a member of the 'server operator' group, or a (domain) administrator?

Also, are you trying to create the shares from the console of the server itself, or through a network connection?

Commented:
When you reinstall NT the filesystem you talking about seems corrctly to NT to be owned by a SID different from yours.
What you have done is the same as deleting your username and then create a new user with the same name. That user will not be able to access the old users files.
What you have to do is to take ownership ower old the files from the old installation because they have sid belonging to the old installation.

Author

Commented:
I may have confused you slightly.  The re-installation involved completely re-formatting my drives and restarting, therefore the only profile I started with was Administrator then I made a copy of this through User Manager to the new login that I am having problems with.  I should also point out that I am an NT workstation rather than the server.

Thanks for your response, any more ideas ?
Did you install & activate the server service? Without this you can't share anything.

Author

Commented:
Yes, it's running OK.  Somebody else has also had the same problem here and left it but after adding a new disk to his PC it suddenly became available again!

I've also tried creating an administrator level login without copying the original Administrator login without any success.

Commented:
Check if this account has rights to share directories (User manager, Policies, User rights, show advanced, create permanent share objects). If no, try to add this rights to needed groupe or account. If it's not successful -- regect my answer.
Best regards, Eizens
1)In the explorer select a directory then do file|properties is the sharing tab there?

2)Create a new account, add to the administrators group.  Login with this account, is it any different.

Author

Commented:
kevinb

No, it still doesn't work.  (See "Comment from Shaley" after "Rejected answer from Rincewind")
Did you set up the machine as a "primary domain" controller?  If you did not, you cannot access administrator functions from a workstation.  If you set it up as a stand alone server, you can try to enable the share from the server console.

Commented:
sounds like time for a rebuild, again,

Author

Commented:
Just what I wanted to hear!

I've done it before though so I'm not sure it will cure anything.  I've shared my drives via the server so people within my domain can access them - that'll do for now!
You must add this account to global group: Domain Admins
and to local group: Administrators

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Thanks!

It seems so simple and obvious I'm not too sure a) why our "experts" here couldn't fix it and b) why it took so long for somebody to answer it correctly!
a) to less point, to simple, ... I don't know
b) I would have done it earlier, but have never checked this topic, 'cause i thought I'm not an expert :-)

Anyway, your're lucky, that's ok.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.