• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 365
  • Last Modified:

Adaptec 1520A/1522A troubles

Hello all,

I have been having problems getting my adaptec AHA-1520A/1522A SCSI card working. It only has my ZIP drive hooked up to it. It worked fine a while back (I forget exactly how long, a month or so). Though I have done a system upgrade since then. I've upgraded to a SuperMicro P6DNF with dual PPro150s. I also started using DMA support
with my Western Digitial hard drives.

Some general info: I have kernel 2.0.30, libc-5.3.12. It's basically a RedHat 4.0 system that I've hand upgraded most of it to 4.1 with a few packages from 4.2.

Whenever I try to load the aha-152x driver (either using kerneld or with insmod). It seems to start up ok, then dies with the following errors (taken from /var/log/messages):

Jul  8 00:40:05 kali kernel: (all the lines below started with this)

aha152x: BIOS test: passed, auto configuration: ok, detected
      1 controller(s)
aha152x0: vital data: PORTBASE=0x340, IRQ=11, SCSI ID=7,
      reconnect=enabled, parity=enabled,
      synchronous=disabled, delay=100, extended
      translation=disabled
aha152x: trying software interrupt, lost.
aha152x: IRQ 11 possibly wrong.  Please verify.
scsi1 : Adaptec 152x SCSI driver; $Revision: 1.18 $
scsi : 1 host.
scsi : aborting command due to timeout : pid 0, scsi1,       
      channel 0, id 0,lun 0 0x00 00 00 00 00 00

(All the lines above each appeared twice, I deleted the
 duplicates and I idented the wrapped lines.)

I've tried changing the IRQ and removing all non-essential cards but the scsi-controller but it still gives that irq error. I've tried going back to kernel 2.0.28, and compiling it without SMP support. I've tried giving it specifics with insmod (ie. 'insmod aha152x aha152x=0x340,11,7). I've
even tried shutting off DMA support (ie. 'hdparm -d0').

I know it's not a hardware problem, as it all works perfectly fine in Dos. The IRQ and SCSI ID are set correctly on the board. The ZIP drive is set to SCSI ID 5 if that means anything to you.

Thanks,

John Eikenberry
[jae@ai.uga.edu - http://www.ai.uga.edu/students/jae/]
____________________________________________________________
"A society that will trade a little liberty for a little
 order will deserve neither and lose both."
                                         --B. Franklin


0
sakti070897
Asked:
sakti070897
  • 2
1 Solution
 
cedricCommented:
Hy,

well, it seems you forgot to assign an IRQ in your mother board's bios PnP/IRQ setup.

By default, on many brand new main board, the IRQ are all for PnP/ICU controlled cards. The 1520/1522 is NOT. So go into you bios and assign IRQ 11 to be free for ISA cards. Save reboot and you should be ok.
Byby.
0
 
sakti070897Author Commented:
Thanks a ton Cedric. I completely forgot about having
to change the bios settings. If you are ever going to
be in Athens, GA, drop me a line at jae@ai.uga.edu and
I'll buy you a beer. :)
0
 
cedricCommented:
Hy,

i'm happy for you and thanks for the beer :^)

byby
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now