Remote Boot into Linux

I am trying to setup a win95 box to remote boot into Linux.
I have a Linux acting as a server which provides NFS, bootpd, tfptd, and rarp services.

Since i have no experience in boot rom, i chose to use a floppy to remote boot from the win95 box.
I've tried using all.com(from etherboot package) as dos shell on a msdos boot floppy, ne.floppy( from netboot-floppy
package) loaded into the boot floppy, and a loadlin boot floppy using an appropriate kernel to do remote booting.

In each way I failed , with the same message after the root
has been mounted from the NFS(linux) server:

 Unable to open an initial console.

Each kernel used in each way is 2.0.30 which has compiled-in bootp, rarp, NFS, root on NFS, and network support of course.
The kernel used in the 1st and 2nd method are tagged using
mknbi-linux from the  netboot package. I have RTFM and couldn't find any answer.

Hope somebody can help me.....
stylonAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
marginConnect With a Mentor Commented:
According to the message is there no faults during the actual mounting/booting procedure. So forget that with bootpd,rarp... - It WORKS!

The problem seems to be your root file system. You have either forgot to do a '/dev/' directory or have incomplete/faulty files in /etc/rc.d. If you have a root floppy mount that one and check out what is needed to make a minimal linux-system working.
0
 
ahoffmannCommented:
See in BootPromt-HOWTO  for booting via NFS. Some distributions
also have a nfsroot.txt anywhere.

Just use a floppy containing DOS, loadlin.exe  and a config.sys
which installs loadlin.exe. Use somthing like:
      nfsroot=[<server-ip>:]<root-dir>[,<nfs-options>]
as parameter to loadlin (see docu for details).

0
 
stylonAuthor Commented:
I did it.
I have a option for loadlin:
nfsroot=192.168.5.2:/boot/share,defaults

And the problem was not solved.
That's why i posted here for help....

0
 
stylonAuthor Commented:
Now I'm using RedHat Linux 4.2,
And it WORKS!!

Maybe it is the /etc/rc.d or /dev problem as you mentioned..
Thanks anyway!

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.