Solved

PPP defaultroute problem(s) (?)

Posted on 1997-07-10
5
412 Views
Last Modified: 2012-05-04
I'm using PPP (specificly, pppd v. 2.2.0f), and I use the defaultroute option.  My problem is that, oftentimes, the default route doesn't get set up.

I have used the "debug" and "kdebug 7" options for pppd. In
/var/adm/syslog, this is the error message which seems relevant (the machine name is linuxer):

Jul  9 22:10:51 linuxer pppd[286]: Could not determine remote IP address

Looking at the pppd source code (in ipcp.c), it seems the remote IP address seen by pppd is 0.  However, sometimes pppd manages to recover and successfully establish the defaultroute through the PPP connection.  For example, in establishing the PPP connection I'm using at this moment,
/var/adm/debug shows:

Jul  9 23:28:54 linuxer pppd[7747]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01>]
Jul  9 23:28:54 linuxer pppd[7747]: rcvd [IPCP ConfReq id=0x3 <compress VJ 0f 01> <addr 128.8.10.106>]
Jul  9 23:28:54 linuxer pppd[7747]: sent [IPCP ConfAck id=0x3 <compress VJ 0f 01> <addr 128.8.10.106>]

Another example (of success):

Jul  9 22:59:05 linuxer pppd[7057]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01>]
Jul  9 22:59:05 linuxer pppd[7057]: rcvd [IPCP ConfNak id=0x1 <addr 128.8.140.111>]
Jul  9 22:59:05 linuxer pppd[7057]: sent [IPCP ConfReq id=0x2 <addr 128.8.140.111> <compress VJ 0f 01>]
Jul  9 22:59:05 linuxer pppd[7057]: rcvd [IPCP ConfAck id=0x2 <addr 128.8.140.111> <compress VJ 0f 01>]

As an example in which the default route doesn't get set up, there's one facility at which I've *never* been able to establish a default route using pppd.  However, I'm told this facility is identical to the one I use successfully, and I can use this site just fine if I connectthrough Windows 3.1 (Trumpet Winsock).  Here is what /var/adm/debug
shows for the unsuccessful connection with Linux/pppd:

Jul  9 22:59:02 linuxer pppd[7057]: rcvd [LCP ConfReq id=0x2 <mru 576> <asyncmap 0x0> <magic 0x49cac9bd> <pcomp> <accomp>]
Jul  9 22:59:02 linuxer pppd[7057]: sent [LCP ConfAck id=0x2 <mru 576> <asyncmap 0x0> <magic 0x49cac9bd> <pcomp> <accomp>]
Jul  9 22:59:02 linuxer pppd[7057]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01>]
Jul  9 22:59:02 linuxer pppd[7057]: rcvd [IPCP ConfReq id=0x3 <compress VJ 0f 01> <addr 0.0.0.0>]
Jul  9 22:59:02 linuxer pppd[7057]: sent [IPCP ConfRej id=0x3 <addr 0.0.0.0>]
Jul  9 22:59:02 linuxer kernel: ppp_tty_ioctl: get flags: addr bffff4ec flags f000010
Jul  9 22:59:02 linuxer kernel: ppp_tty_ioctl: get flags: addr bffff500 flags f000013
Jul  9 22:59:02 linuxer pppd[7057]: rcvd [IPCP ConfReq id=0x4 <addrs 0.0.0.0 128.8.140.111> <compress VJ 0f 01>]
Jul  9 22:59:02 linuxer pppd[7057]: sent [IPCP ConfRej id=0x4 <addrs 0.0.0.0 128.8.140.111>]
Jul  9 22:59:02 linuxer pppd[7057]: rcvd [IPCP ConfReq id=0x5 <compress VJ 0f 01>]
Jul  9 22:59:02 linuxer pppd[7057]: sent [IPCP ConfAck id=0x5 <compress VJ 0f 01>]

-----(end of examples)-----
I've tried fiddling with various pppd options (e.g. -vj) but I still have no success.  What am I doing wrong here?

BTW, here are all the pppd options I'm using:
debug kdebug 7 asyncmap 0 noipdefault lock crtscts 57600
...and I'm running Linux kernel version 2.0.27, with PPP support compiled as a module in the kernel.

Many thanks for any and all help,
--daniel

0
Comment
Question by:DanielEFriedman
  • 2
  • 2
5 Comments
 
LVL 3

Expert Comment

by:sauron
ID: 1585391
Do the problem sites assign you a dynamic or a static IP address?

I have had trouble in the past, using a static ip. SPecifying the IP on the pppd command line fixed the problem.
0
 

Author Comment

by:DanielEFriedman
ID: 1585392
<sauron> has asked if the problem sites assign a dynamic or a
static IP address.

The answer: dynamic IP addresses are assigned in all cases described in my question: the always-good, the always-bad, and the flaky.
0
 
LVL 2

Expert Comment

by:cedric
ID: 1585393
Hy,
have you tried ipcp-accept-local
and ipcp-accept-remote

Here is my /etc/ppp/options
user jhonny
ipcp-accept-local
ipcp-accept-remote
noipdefault
defaultroute
debug
-detach
lock
-vj
-bsdcomp
modem

and btw, you can't have ppp compiled in the kernel AND as a module. It is one or the other, but not the 2 at the same time.
0
 

Author Comment

by:DanielEFriedman
ID: 1585394
<cedric> has offered an answer which I'd grade as "B" except
that I tried his suggestions and my problem remains (and I'd
still really like to get an answer).

(And what I meant to say regarding PPP support is that I'm running PPP as a module and that the kernel
is compiled to support PPP as a module.)
0
 
LVL 2

Accepted Solution

by:
cedric earned 170 total points
ID: 1585395
Hy again,

So, i suggest you to compile the last PPP package available :
ppp 2.3.1 (at sunsite). Compile it in the kernel, not as a module. This way you should not mater (for now) to be up to date with the modutils packages. Bennefit are the integrated dial on demand feature and new extended PPP parameters.

Maybe the site wich you are connecting on is using NT special features, wich have been longly discussed in this site. So to agree with NT, adjust your compile options of the PPP daemon. (MSCHAP).

You can try (as a temporary try) to lower you connect speed 57600 --> 38400. And to insert waiting time in your chat script if your ISP is a little slow or very heavy one.

And as a last one, you should upgrade your linux kernel to the 2.0.29 (not the 2.0.30 wich is a little buggy).

Keep using the parameters in my first answer.

Do all of these and come back to tell me.

0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now