Solved

Win95 and cd-rom trouble

Posted on 1997-07-11
29
314 Views
Last Modified: 2013-12-16
I bought a new Quantum Fireball 3,2MB harddrive as a slave with my old Seagate 1.2MB. Now I can't boot win95 if my (aztech 268) cdrom is plugged in (if ide cable is connected). Cd is in the second ide port as a slave. Win95 bombs me with Protection errors and others, randomly. It also sometimes asks me to use the backup register. After removing the ide cable from the cd drive everything is fine. In DOS cdrom-drive works fine. What is wrong???
0
Comment
Question by:ld0d
  • 12
  • 6
  • 4
  • +5
29 Comments
 
LVL 12

Expert Comment

by:j2
Comment Utility
Win 95 doesnt like to have a secondary slave if th4ere isnt a master present. Reconfigure teh drive to reside as secondary master.
0
 

Author Comment

by:ld0d
Comment Utility
It worked until I bought that Quantum....
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
If your HD meets these spec's then see:
http://www.microsoft.com/kb/articles/Q60/7/82.htm
----------
Part number: P/N BFxx011-Rev03-D
A serial number ending in "S"

If not reject this answer.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Is Quantum scsi, and check in device manager under "Hard disk controllers, and see if Busmastering is supported.

If your HD requires a hardcard; Then do this:
-----------
Most hardcards must load drivers from the CONFIG.SYS file to
provide read and write capabilities. If
these device drivers do not load, you can only read
information from the hard disk. Without the ability
to write information to the hard disk, Windows 95 cannot
rename the CONFIG.DOS,AUTOEXEC.DOS, IO.DOS, and MSDOS.DOS
files to boot to MS-DOS. (Other operating systems
may use different filenames.) This forces Windows 95 to boot
using the Windows 95 IO.SYS file.
Because the file-rename process occurs before the CONFIG.SYS
file is read, the device drivers are
not yet loaded; therefore, the files cannot be renamed.
0
 

Author Comment

by:ld0d
Comment Utility
Nope...didn't help. I don't know that part number (well...I bought that hd from my brother) ...and I don't know where to find the p/n. And, I don't live in America, so those numbers don't help.
0
 

Author Comment

by:ld0d
Comment Utility
I suppose that my cd creates some kind of read errors or something...those registry errors are strange... and setting the drive as master didn't help. Only thing that happened was that my bios found it...and it took longer to boot :( ... i guess it tried to look for another ide device... dos still works. I got win95 to boot (luckily) and it said that there was no cd in drive (there was!) . Is there some kind of a conflict??? well..i don't have any drivers for my hd, and cd's drivers don't help. I have a Zappa motherboard and a Pro Audio Spectrum 16 soundcard (with scsi). And a Diamond Stealth 64 VRAM videocard ... does this help?
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
I asked the numbers because some Quantum's are incompatible, with fix's in the bios.
-----------------
DEVICE MANAGER STUFF:
If there is a problem with a device, it is listed in
the hardware tree list under Computer. The
problem device has a symbol indicating the type of problem:

A black exclamation point (!) on a yellow field indicates
the device is in a problem state. A
device in a problem state can be functioning.
A problem code explaining the problem is
displayed for the device.

A red "X" indicates a disabled device. A disabled
device is a device that is physically present
in the system, consuming resources, but does not
have a protected-mode driver loaded.

A blue "i" on a white field on a device resource in
Computer properties indicates that Use
Automatic Settings is not selected for the device and
that the resource was manually
selected. It does not indicate a problem or disabled state.

NOTE: Some sound cards and video adapters do not report all
the resources they are using to Windows 95. This can
cause Device Manager to show only one device in conflict, or no
conflicts at all. This can be verified by disabling the
sound card, or using the standard VGA
video driver too see if the conflict is resolved.
(This is a known problem with S3 video cards
and 16-bit Sound Blaster sound cards, or those sound cards using Sound Blaster
emulation
for Sound Blaster compatibility.)
When you select a specific device in Device Manager,
then click the Properties button, you
see a property sheet. The property sheet has a General tab.

NOTE: Some devices may have other tabs besides the General tab.
Not all property sheets
have the same tabs; some devices may have a Resource tab,
Driver tab, and Settings tab, or some combination of these.

At the top of the property sheet, there is a description
of the device. When you click the
Resource tab, the window in the middle of the tab indicates
which resource types are available for the selected device.

The scroll box at the bottom of the contains a Conflicting
Device list. This list indicates a conflict with an error code.
Note the Use Automatic Settings check box. If Windows 95
successfully detects a device,
this check box is selected and the device should function
correctly. However, if the resource
settings are based on Basic Configuration <n> (where <n> is
any number from 0 to 9), it may
be necessary to change the configuration by selecting a
different basic configuration from the
list. If the particular configuration you want for the
device is not listed as a basic configuration,
it may be possible to click the Change Settings button to
manually adjust the resourcevalues.

For example, to edit the Input/Output Range setting, use these steps:
1. Click the Use Automatic Settings check box to clear it.
2. Click the Change Setting button.
3. Click the appropriate I/O range for the device.
----------------
Please see:http://www.microsoft.com/support/tshoot/w95startup.HTM

0
 

Author Comment

by:ld0d
Comment Utility
Well...a couple of days ago there were some of those ! -marks in the device manager, but now they seem to have disappeared...
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Check and recheck your cable chain. And experiment with it.
Get back to me with what you did.
0
 

Expert Comment

by:silicool
Comment Utility
Its very easy, i gus you use Intel motherboard whith Intel 82371SB PIIX3 chip IDE control. You trobles in Win95, becouse (4.00.950) not support
enhansed Intel port, but you can find "Install Wizard" wich correct this problem, and you CD-ROM will work OK & second IDE too.
www.intel.ru/contents/mothers/motherbd/idecdrom.htm (Russian) probably enable on www.intel.com
0
 

Author Comment

by:ld0d
Comment Utility
no...that cable stuff didn't work.....but something strange: When I removed my Diamond drivers (i have umm... Diamond Video Vram 3200 ... guess it's that ... with 2mb vram) and booted with standard vga it booted twice (2)  and then it reported those same old errors...undefined dynalink/protection error/bad registry/that blue screen etc. TO SILICOOL: nope...that fix doesn't help (i guess) because my device manager shows me two (2) "Standard IDE/ESDI Hard Disk Controller"s ...but well, i can try.
0
 
LVL 3

Expert Comment

by:Ikon
Comment Utility
Lots of issues with IDE CD-ROMS connected onto same cables as EIDE drives, one of which is it makes your drives transfer data at the same rate as the CD!!!!!
So you might have a really fast HArd drive, but if it is on the same cable as your 2xCD it will run at the same speed as 2X cd!!! heh.
Smeebud is right configure the jumpers on the CD-ROM to be master on the second EIDE bus connector.
Does your sound card also have an ide connector on it?? if so consult your documentation on how to disable this, this can conflict with secondary eide channels sometimes.
0
 
LVL 1

Expert Comment

by:theyak
Comment Utility
What bios are you using??? Mine has a confirmed 3+ ide spin down
problem and I can d/l and re flash the bios. Check your bios homepage


0
 
LVL 3

Expert Comment

by:Ikon
Comment Utility
It may have something to do with the Quantum Fireball being a DMA33 drive? and as theyak said, your BIOS may not support this properly.
Hello? anybody home?
0
How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

 
LVL 3

Expert Comment

by:Bogey
Comment Utility
Dont use the quantum drive in conjunction with the seagate.  Mixing brands of IDE hard drives causes random data corruption, and lockups.  Even if they are on separate controllers.  

There are KNOWN incompatabilities between Seagate and Quantum, Seagate and WD, Quantum and WD, Maxstor, IBM etc...  

The problems you are receiving, even though they seem related to the CDROM, are only magnified by the presence of the CDROM.  You will continue to have system problems unitl yuou remove either the Quantum of Seagate drive.  

I know it is not an easy answer, but the best solution would be to backup the seagate, install the quantum as primary (removing the seagate), restore the system to the quantum, and live with the 3.2GB drive.

Or if possible, return the quantum and swap for another seagate.
0
 

Author Comment

by:ld0d
Comment Utility
Hmm...i gotta check that harddrive conflict stuff...my pas16 has a scsi-connector, not ide...I'm using bios 1.00.04.bs0 ...i guess...i'll be back in a couple of days...i don't have too much time now, because assembly'97 is coming...i'll check this place almost every (or every other) day...
0
 
LVL 1

Expert Comment

by:pcservice
Comment Utility
what i would do is configure your 1.2Gig hard drive as a primary master, your cd as a primary slave, and then try to see if you still have the same problem, if not, install the 3.2Gig on the secondary maste ide i/o

this way your hard drive conflic should be solved
0
 
LVL 3

Expert Comment

by:Bogey
Comment Utility
Mixing IDE brands accross primary and secondary controllers will still cause problems.  It does not make a difference if they share a controller, or are attached to separate controllers.

0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
Bogey has that right on the button. Seperate your Ide and scsi.

0
 

Author Comment

by:ld0d
Comment Utility
Hmmm...seems impossible :( ... win95 setup program hangs if I use AMI BIOS 1.00.04.bs0 ... 1.00.02.bs0 doesn't support >2GB drives. I cant install win95 to my new drive!
0
 

Author Comment

by:ld0d
Comment Utility
no, no, no! I have no SCSI -drives!
0
 

Author Comment

by:ld0d
Comment Utility
perhaps I should ask if I could change my quantum to a seagate.
0
 
LVL 14

Expert Comment

by:smeebud
Comment Utility
That would help. Re-ask the whole question and be very specific.

0
 
LVL 3

Accepted Solution

by:
Bogey earned 200 total points
Comment Utility
I understand the question completely.  You have 3 IDE devices, a Seatgate, a Quatum, and a CDROM.  As before, the Seagate and Quantum in the same machine will cause random data corruption, lockups, and instability.  

Use either the Seagate and the CDROM, or the Quantum and the CDROM, or if you require two hard drives, get two of the same brand.

It makes no difference where the Seagate and Quantum IDEs are attached (Slave/master/primary or secondary). You wil have problems.  Installing the CDROM in the system is only magnifing the issue.
 
0
 

Author Comment

by:ld0d
Comment Utility
I guess that's the final answer :( ... so I just have to change that quantum to a seagate...<sigh> ...well, I'll try...
0
 
LVL 1

Expert Comment

by:pcservice
Comment Utility
You're gonna have to change your cd-rom...
this week we had the same problem and solved it changing the cd-rom. Hope it's gonna work for you !
0
 

Author Comment

by:ld0d
Comment Utility
Well...now it works somehow...I just unplugged quantum, installed win95 (it worked fully...just like before I bought that quantum) and plugged quantum again... now it just restarts explorer if I try to remove files (also on desktop) with del-key. I have to remove them through dos-prompt or by dragging them to recycle bin...slow.
0
 
LVL 3

Expert Comment

by:Bogey
Comment Utility
Sounds like an IDE conflict... This is typical behavior for conflicting IDE drives.  Seem to work, then exhibits weirdness...

Have you considered removing the seagate and run the quantum by itself?

I think you will find it fixes things.
0
 

Author Comment

by:ld0d
Comment Utility
Yeah...i know it might fix everything, but I can't install Win95 without a <2.5GB drive...I will test installing win95 osr2 after assembly '97 ... perhaps it's setup program works better..
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

For a variety of reasons, it sometimes makes sense to reboot a Windows-based computer on a regular, perhaps daily basis. This "cures" a lot of ills by resetting processes, flushing caches, refreshing memory, and reestablish network connections. In a…
A few months ago I had an issue with LaserJet 1020 printer which was installed to XP and Windows 7.  It was installed to XP and working, but when I tried to connect from a Windows 7 PC, it would attempt connection and then fail.  Sometimes the Spool…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now