Linux as gateway to Internet

I can't get my linux to route packets from my win95 client via my linux to the internet. I can see that my modems txd led flashes once when I ping  from the client. I have not compiled my recompiled my kernel, Redhat ver. 4.2.
ckuAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ahoffmannCommented:
Can you ping from your linux gateway?
Have you setup routes at the gateway (netstat -rn).
Can you ping your win95 client?
Can your client ping the gateway?
Have you defined the gateway (the linux-gateway) at your client?

If this all works fine, you have to look at the kernel, you need
at least following settings:
      CONFIG_INET=y
      CONFIG_IP_FORWARD=y


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sbickleCommented:
Are you trying to setup the linux box to do IP Masquerading?  If so once you have all the pieces in place the win95 machine will be able to see out but from what I've found ICMP packets do not pass through this gateway.                                  
0
ckuAuthor Commented:
I am capable of doing all things u suggest, but when I ping the Internet from the client, i can see the txd led on my modem flash a couple of times, but the ping still times out. what is ipfwadm's role in this case?
0
ahoffmannCommented:
ipfwadm accepts or rejects IP packets in either direction, it can
also masquerade and do a accounting (see man page).
I.g. the default setup is to have no restrictions at all. Use
      ipfwadm -I -l
      ipfwadm -O -l
      ipfwadm -A -l
      ipfwadm -M -l
      ipfwadm -F -l
to get a list of current settings.

If your ping times out, it's probably a routing problem, check with
netstat -rn

Ciao Achiim
0
manicCommented:
Just telling you kernel to forward IP packets would be suicide for your network...

At least set up an IP masquerading gateway. This is REALLY easy and REDHAT 4.2 will do it brilliantly...

Just get the IP-Masquerade mini-howto from sunsite.unc.edu
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.