probs with AHA 1522

Hello:
I have recently infomagics' April 1997 cd set containing Slakware and redhat and have had major problems getting the setup procedure going.
I have not formatted the linux partition, so all I want is to get the card and drive recognized. And I do get that far, but then the root disk crashes.
I have tried to be as specific as possible in what I have tried to do and what has worked and what hasn't. That way you can all be as confused as I am. (all this head scratching has made me go bald on my left side)
Anyways, let's start from boot:
Initializing Plug and Play Cards...
Card-01 Adaptec aha-1522B
Card-02 3Com 3c509B EthernetLink III
(both ISA cards,or is it ESA, but not VESA)

Adaptec AHA-1520B/1522B 16KB BIOS v.1.15
I/O PORT=340 IRQ=11 BIOS Address=C8000h
SCSI ID#1 - QUANTUM FIREBALL_TM2110S - Drive C: (80h)

From here, I have tried both Slak and red. Let's do Slak first.
I use the image aha152x.s and scsi, and get the same results.
If I boot passing no parameters what so ever, it does not detect my card, but I do manage to get to the "log in as root and type setup". Of coarse fdisk cannot open /dev/sda and that is as far as I get.
If at the boot prompt I type:
mount aha152x=340,11,0 (I cannot use linux because that is not an option, the other options are: ramdisk, big2, small2, drive2, mount, as shown when I hit tab), I get the following:
aha152x: processing command line:
aha152x: <NULL>
aha152x: invalid line (controller=1)
ok
aha152x: BIOS test: passed, auto configuration: ok, detected 2 controllers
2 controllers?? why 2? is one the card and then the HD?
aha152x: vital data: PORTBASE=0X154, IRQ=11, SCSI ID=0, reconnect=enabled, parity=enabled, synchronous=disabled, delay=100, extended translation=disabled
aha152x: trying software interrupt, lost.
aha152x: IRQ 11 possibly wrong please verify (it is not wrong according to BIOS)
then the vital data line repeats, the trying software line repeats but this time says OK and then,
scsi0: Adaptec 152x SCSI driver; $Revision: 1.18
scsi : 1 host.
vendor..
type...
THEN.. the cool part
Detected scsi disk sda at scsi0, channel 0, id1, lun0 (kewl eh!!!!)
but then,
scsi: detected 1 SCSI disk total.
SCSI device sda: hdwr sector= 512 bytes, Sectors=4124736 [2014 mb]
partition check:
 sda: sda1 sda2 <sda5> (why is sda5 like that? shoudn't it be sda3?)
VFS: Insert root floppy....
I do and...
end_request: i/o error, dev 01:00, sector XXXX
and that repeats about oh... 100 times maybe more.
And that is as far as I get, I have tried using different floppies but get the same thing every time. I have tried using different boot and root images but no luck. dead. damn.

Ok, now for redhat, this is much shorter cuz I die almost immediately.
I boot using the boot.img file cuz there is nothing more specific on the CD, I went to the redhat FTP site but found boot images for the 1540 not 152X URG!
Anyways, so I boot up, I try specifying parameters at the boot prompt but have no effect. Then just before the "Are you sing a color monitor", I see
scsi : 0 hosts
scsi : detected total. Of coarse the partition check does not find my /dev/sda.
Then when I get to the scsi driver, i tell it to auto probe for a Adaptec 152x but it does not find it! I try to specify options but do not know the parameters I should specify (port address=, port_base?, hex or dec values?)
so that is where I die with redhat.

As you can see, I have tried various things out and have yet to find a solution. Any help to get the system going (before my boos shoots me) would be more than apreciated.

PS. I think it took me longer to spell check this thing that to actually type it!

Thanks for your patience and above all your help...
sinner052397Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cedricCommented:
Hy,

please verify in you PnP bios setting that the IRQ 11 is not reserverd for PnP/ICU cards but assigned to ISA cards.
Modify this setting, save your bios, reboot and tell me...

byby
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sinner052397Author Commented:
in my PNP/PCI configuration I already have IRQ 11 showing as "assigned to: PCI/ISA PNP"

0
cedricCommented:
ok, so please, change it to the other value because the adaptec aha 1520-1522 is definitly NOT Pnp.

It's absolutely normal that is doesn't work with irq 11 reserved for PnP. So change it. Save it & it MUST work.

0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

sinner052397Author Commented:
Hi cedric.
I Changed the setting on the CMOS to legacy ISA from PCI/ISA but it still did not work.
Question: If the AHA-1522 is NOT plug and play, why is that when I boot I see the msgs:
"Initializing  plug and play cards...
card-01 adaptec aha1522b
card-02 3com..."

In the host adapter bios I noticed that it has a setting called
"ISA Plug and play Mode enabled" I disabled it but made no difference.
plug and play SCAM support is also disabled

0
cedricCommented:
Oooooh ok i see you have a new one. Ok so this one seems to be effectively Plug n Pray :^)

So, you have to do exactly se opposite as my last answer AND you have to install and configure isapnptools for your card to be correctly recognized.

Or (but i'm not sure) maybe you can disable the Pnp setting of your bios aha1522b card AND use legacy ISA for irq 11.

To resume myself : use everything in Pnp mode or everything in not Pnp mode.

Btw, verify that no others boards are currently using irq 11.

Byby.

0
sinner052397Author Commented:
Hi Cedric.
I have pretty much given up on the idea of getting my card auto-detected. I figured that it woudn't be a big deal if all I have to do to fix the problem is install LILO, of coarse after I install the system. do you think that the
"end_request: i/o error, dev 01:00, sector XXXX "
error is also IRQ related? The reason why I'm asking is because when I use the boot and root disks from the latest release I get that error and can't install. But when I use the boot and root disks from an older CD (kernel 1.2.13) I get into the setup section with out any problems.
Could the "end_request: i/o error, dev 01:00, sector XXXX " error also come due to the fact that I have 2024 cylinder on my SCSI HD?
Thanks again.

0
cedricCommented:
Hy,
well, scsi adapters do their own translations chame for hard drive with more than 1024 cylinders. But, in some cards you have an option to disable this feature. Can you go into your card bios and tell me every settings you can read ?
Byby.
0
sinner052397Author Commented:
Sure thing. Here goes:
First menu is options: 1) Configure/view host adapter settings and 2) disk utils. Disk utils only has verrify media or format.
In configuration I see.
Host adapter interface Deinitions
   Host adapter IRQ channel.......11
   Host adapter DMA Channel.......Disabled
   Host adapter SCSI ID...........0

Scsi Channel Interface Definitions
   SCSI Parity Checking...... Enabled
   Host adapter SCSI Termination... Automatic

Additional Options
  SCSI Device Config..... <press enter> and when I do I see

   SCSI Device ID            #0    #1
   Initiate Sync Negotion    yes   yes
   Max Sync Transfer rate    10.0  10.0
   Enable Disconection       yes   yes
   Options listed below have NO EFFECT if the bios prom is disabled
   send start Unit command   no    no

advanced Configuration options.. press enter.
I do and see.
   ISA Plug and Play mode ..... enabled
   PnP SCAM Support............ disabled
   Options listed below have NO EFFECT if the bios prom is disabled
   Host adapter BIOS........... Enabled
   Support Removable disk under bios as fixed disk.... Boot only
   extended BIOS translation for DOS drives > 1gig.... disabled
that's it!
what's BIOS PROM? I coudn't find it in the scsi bios.
 
0
cedricCommented:
Hello,
so at the looking of your settings i can recommend the followings :
dma : enable it and (if possible) fix it to : 1 3 or 5 depending if you also have a sound card

Host adapter scsi ID : 7 of course like every scsi ha in the world (expect of course IBM's one).

extended BIOS translation for DOS drives > 1 gig : enable.

the prom is the physical chip where the bios reside.

Hope this time you'll be ok with this scsi board.

Byby.

0
sinner052397Author Commented:
Hello cedryc,
Unfortunately today was the deadline and I had to give the client the computer. I manged to install LILO by partitioning the hard disk into >1gig partitions and lying to FDISK about the dimensions. I passed LILO the append line to detect the controler card and that was that.
Not a perfect solution, but one that works.
Thank you for your help. A++ for effort! ;-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.