Cannot read long filenames from CD-ROM

I have a Matsushita (Panasonic) CR-581 CD-ROM drive. I am using the latest Windows 95 driver from Matsushita, so it is unlikely that this is a real-mode driver. However, I cannot read long filenames with it. It only reads the DOS filename.  My computer does not seem to be loading any other real-mode or protected-mode cd-rom drivers (in config.sys or elsewhere) that may be causing this problem. What should I do to be able to read long filenames from my CD-ROM drive?
mariosAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wwillisCommented:
What are you looking at the files with?  Meaning, are you running File Manager (winfile.exe) in Win95?  If so it won't show long filenames.  If you shell out to DOS and do a dir does it show long filenames or 6~1.3 form?  Windows Explorer?  Is it just the cdrom? Meaning, if you go into Explorer and click on the C: drive does it show long filenames and them you click on D: (or whatever the drive letter is) does it revert to short filenames?  Is this the same no matter which disk you put in the cdrom drive?

   <--Will-->  MCSE, A+ Certified Technician
0
smeebudCommented:
After you answer wwillis's *valid and necessary* questions; try running the File system troubleshooter as follows:
------
To display the file system troubleshooting options, follow these steps:It's here and  http://www.microsoft.com/kb/articles/q165/5/03.htm
--------------------
1.In Control Panel, double-click System.

2.Click the Performance tab.

3.Click File System.

4.Click the Troubleshooting tab.

The following table describes the settings on the Troubleshooting tab:

File system option    Description
-----------------------------------------------------------------------
Disable New File      This option alters the internal rules for file
Sharing And           sharing and locking on hard disks, governing
Locking Semantics     whether certain processes can have access to
open files in certain share modes that guarantee
a file will not be modified. This option should
be checked only in the rare case that an
MS-DOS-based application has problems sharing
under Windows 95. This sets SoftCompatMode=0 in
the registry.

Disable Long Name     This option turns off the tunneling feature,
Preservation For      which preserves long filenames when files are
Old Programs          opened and saved by applications that do not
recognize long filenames. This option should be
checked in the rare case that an important legacy
application is not compatible with long
filenames. This sets PreserveLongNames=0 in the
registry.

Disable Protected-    This option prevents Windows 95 from terminating
Mode Hard Disk        interrupts from the hard disk controller and
Interrupt Handling    bypassing the ROM routine that handles these
interrupts. Some hard disk drives might require
this option to be checked in order for interrupts
to be processed correctly. If this option is
checked, the ROM routine handles the interrupts,
which slows system performance. This sets
VirtualHDIRQ=1 in the registry. (This setting is
off by default for all computers in Windows 95,
which is the reverse of Windows 3.x.)

Disable All 32-Bit,   This option ensures that no 32-bit disk drivers
Protected-Mode        are loaded in the system, except the floppy
Disk Drivers          driver. Typically, you would check this option
if the computer does not start due to disk
peripheral I/O problems. If this option is
enabled, all I/O will go through real-mode
drivers or the BIOS. Notice that in this case,
all disk drives that are visible only in
protected mode will no longer be visible. This
sets ForceRMIO=1 in the registry.

Disable Write-        This option ensures that all data is flushed
Behind Caching        continually to the hard disk, removing any
For All Drives        performance benefits gained from disk caching.
This option should be checked only in the rare
cases where you are performing risky operations
and must ensure prevention of data loss. For
example, a software developer who is debugging
data at Ring 0 while creating a virtual device
driver would check this option. This sets
DriveWriteBehind=0 in the registry.


Each option sets a value in the following registry key:

Hkey_Local_Machine\System\CurrentControlSet\Control\FileSystem
0
mariosAuthor Commented:
Answers to wwillis's questions:
I am using Explorer to browse the contents of the CD-ROM. The problem is only with CD-ROMs. I can read long filenames from my hard disk both with Explorer and the DOS dir command. Actually the problem is more apparent when I try to do an installation from a CD-ROM that contains long filenames. In that case the installation program gives me the following message: "Setup has detected that your CD-ROM driver cannot read long filenames from the CD-ROM. Setup will not be able to install this product from the CD."
0
OWASP: Forgery and Phishing

Learn the techniques to avoid forgery and phishing attacks and the types of attacks an application or network may face.

mariosAuthor Commented:
My settings were already as in smeebud's answer.
0
smeebudCommented:
Very Strange,
Go to http://www.microsoft.com/kb/default.asp
At Step 1 choose windows95
At step 5 enter "long filenames"  no qoutes.
See which articles apply to you.
Get back to me.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
smeebudCommented:
marios,
tell me what you finally did please.
Also, on long filenames, I have not been idle, see:
Errors Creating Files or Folders in the Root Directory
http://www.microsoft.com/kb/articles/q120/1/38.htm


0
mariosAuthor Commented:
I got an answer from the hardware manufacturer that the driver I was using "was for DMA tranfer". I didn't know what that meant but I followed his instruction and used the Windows 95 driver (ESDI_506.pdr). It worked.  
0
smeebudCommented:
marios,
This was a niw one on about everbody. We all thought you were probably using your old file manager, "winfile".
You'd really be doing me a big favor if you would let me knoe those instructions from the manufacturer. i'd be able to help others in the future with that. So if you don't mind:
bwil@erinet.com

BTW, good work.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.