openurl.exe

I can no longer Open the Favorites I've Organized in Internet Explorer 3.02. When I try to do so, I receive a message that openurl.exe is needed. (This program is needed for opening files of type "Internet Shortcut.")

I can open bookmarks in Netscape Navigator.

I suspect that my problems originated when I downloaded/installed IE-Safe from Eliashim. This supposedly addresses a fairly recent security problem with IE (not the most recent one identified by Bell Labs).  IE-Safe works - I think - by preventing remote access to shortcuts, while enabling local access.

Since I had previously installed the Microsoft patch, I guess I wasn't too surprised when I received the following message when I began logging on to my ISP:

"Access to specified device, path, or file is denied"
(White X inside red circle)

I could still complete the process of logging on to the Internet.

I contacted Eliashim and was told to uninstall IE-Safe using the Uninstall function.  I was also told to edit the registry and remove all traces of Eliashim and IE-Safe.  I did so and my problems Opening the Favorites I've Organized in IE 3.02 surfaced immediately afterwards.

I contacted an IE-sing friend and told him to e-mail me a copy of openurl.exe.  He said he doesn't have it.

Eliashim/ESafe said they do not support patches to IE-Safe and can't help me.

Update:

Eliashim/eSafe has offered to help me.  It seems that urlopen.exe is a file installed to Windows by IE-Safe.

I have been advised to edit the Registry as follows:

Under HKEY_CLASSES_ROOT\InternetShortcut\shell\open\command the default value now says -  "C:\WINDOWS\urlopen.exe %1"
The default value needs to be changed to -
"rundll32.exe url.dll,OpenURL %1"   This is the value listed under OldApp.

So my question becomes how - running Regedit - do I delete the current default listing and then make the current default listing what is now listed as an OldApp ?

I am assuming I should delete my current default listing ("...\urlopen.exe %1") because I have already eliminated all traces of IE-Safe and Eliashim in the Registry and in Windows.






endlessAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

endlessAuthor Commented:
Edited text of question
0
feenixCommented:
Yes, you have to delete the default listing and return to the value under oldapp. Just click on the default value, delete, and then there could be a key-renaming function also that would allow you to change the name of the key to the default.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
endlessAuthor Commented:
The nature of my problem keeps mutating. By the time I read your answer, I had already figured out how to edit the registry to change the name of the key to the default I want.

Unfortunately, I still cannot Open Favorites I've Organized in IE 3.02.  I see the desired default value when I click from View-Options-Programs(tab)-File Types-Internet Shortcut. Action-Open.  Application used to perform action: "rundll32.exe url.dll,OpenURL %l"

Still, when I try to Open a Favorite I've Organized, i get the message: "PROGRAM NOT FOUND. Windows cannot find ________.url" (Example: VeriFone, Inc.url) " This program is needed for opening files of type 'Internet Shortcut'.  Location of _______.url:  C:\ " (This is highlighted.)  "OK   Cancel   Locate"
(When I chose Locate, I saw "BROWSE FOR FOLDER.  Locate: Specify the folder that contains __________.url."

When I right mouse-click on a Favorite and go to Properties-Internet Shortcut, I see that the Target Url is filled out correctly.  The Start In space is empty. The word "None" is next to Shortcut Key. "Normal Window" is next to Run.
0
endlessAuthor Commented:
My problem has been resolved.  No need to answer. (I'll keep the additional 100 points, if you don't mind!)      ;-)

The advice I receive from Eliashim was correct.  I made a mistake when I edited the Registry by putting double quotation marks around the default value.  When I retyped the default value and left out the quotation marks, my problem was solved.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.