[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 241
  • Last Modified:

Playback whit ActiveMovie 1.0

Hi, my problem is when I want to make more than
one (1) playback in a DirectX 3.0 application using ActiveMovie 1.0 for playback, my main window goes in minimize state to the task bar.

I make the playback in my main window, I have to use the function  put_Owner((OHWND)m_hWnd) from the interface IVideoWindow then use the function put_WindowStyle(WS_CHILD|WS_CLIPCHILDREN| WS_CLIPSIBLINGS); from the same interface.

It's play like i suppose everything it's fine....

But when I want to playback again here's the problem and my mainwindow goes in minimize state in the task bar.

Everytime I play a media I initialise every interface the when I it's over I release all interface and before I close the graphbuilder interface I put the Owner of the window to NULL like this put_Owner(NULL); from the interface IVideoWindow.


One more thing do you know where I'll can found the beta version 2.0 of ActiveMovie.

Thank You for your help, Sylvain....
0
sylvaind
Asked:
sylvaind
1 Solution
 
vinniewCommented:
I think this will work:

Find the handle to your main window.

Enumerate child windows.

SetFocus to the one you want.
post a SW_MAXIMIZE message to it.

V

If this doesn't work, post more code.

0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now