Modem setup

I was trying to use 'seyon' to dial up in the xterm of X-window. After I type 'seyon', then press return, I got the message which is showed below:
  Initialization error
Modem initialization routine failed.
Possible causes:
* no modem device is specified.
* modem device is locked.
* failure to open modem device(e.g. non-existent port, insufficient permission, etc).
Suggested action:
* check that you specified the correct port.
* check that no other process is using the modem.
I actually specified the correct port(cau1--com1:under DOS which works fine with no problems in win95) during setup configure procedure.It's impossible that other process is using the modem, and I did see a link file modem -> cua1 under /dev. How come?

your help will be appreciated!

Wu


wuyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ahoffmannCommented:
To check if there is another process on the device, look at:
/usr/spool/uucp or /var/lock

> cau1--com1:under DOS
  ^^^^^^^^^^
No, no, ..  cua0 is DOS's COM1 !

> modem -> cua1 under /dev. How come?
This link was probably generated during installation.
You should set it to the right device. Some HOWTOs even tell you not to use the cua* devices but the ttyS* instead.

Then use "minicom -s" as user root to check basic functionality of your modem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wuyAuthor Commented:
Sorry, I mistook! The 'cau1 com1: under DOS' should be cua1 com2: under DOS. I did correct option!

I can't use ttys* instead of cua*.I can't type in anything in menu option during setup configure.

Go into Linux as soon as I turn computer on. So it is impossible that another process is using modem.
0
ahoffmannCommented:
ttyS*  **not**  ttys*

> I can't type in anything in menu option
What do you mean by that?
0
wuyAuthor Commented:
You are right. The ttyS* is not ttys*, but this is not the reason
which causes my problem.

"I can't type in anything in menu option" means when I setup configure during installation, it's a menu option allows me choose cau0, cau1, cau2 & cau3 only. No chance to type in anything.
0
wuyAuthor Commented:
I login as root, then go to /dev. I delete 'modem' link file using 'rm' command. Then, I tyied all ways below:

   ln -s /dev/cua1 /dev/modem
   ln -s /dev/ttyS1 /dev/modem
   setserial /dev/cua1 auto_irq
   setserial /dev/modem autoconfig

The linux still coundn't recognize modem. No response from modem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.