Solved

COM3 & COM4 seem ok but don't work

Posted on 1997-08-02
6
783 Views
Last Modified: 2013-12-16
I have added a new COM3 and COM4 to my computer, and
configured them accordingly, except that I put COM3 on
a seperate interrupt (IRQ9).

I have tested it by moving my modem to the COM3 port, and when I poll for 'more info...' it works, but dialing out,
it tells me that it could not successfully connect with the
modem (the real end use if for a digital camera, and it also
thinks there are problems with the COM port)

The Device Manager says everything is OK, and I am running a
166MMX, 430TX, Adaptec SCSI, Matrox Mystique, SB AWE 64 based system.  The only thing is that looking at the system
resources by IRQ or mem address, I find there is this little
serial port icon with an 'i' in it.  Don't know what that is, but it differs from COM1 & 2 already there.
0
Comment
Question by:blakef
6 Comments
 
LVL 14

Expert Comment

by:smeebud
ID: 1749932
Check it out with a modemdet.log, then get back with me,
----------
To enable the creation of the Modemlog.txt file, follow these steps:
1. In Control Panel, double-click Modems.
2. Click the modem you want to create a log file for, and then
click Properties.
3. On the Connection tab, click Advanced.
4. Click the Record A Log File check box to select it, and then
click OK.
5. Click OK, and then click Close.
After you follow the above steps, the Modemlog.txt file is written to
whenever a communications session is established by a TAPI-enabled
communications program (such as HyperTerminal, Phone Dialer, or
Dial-Up Networking). Note that programs that are not TAPI-enabled do
not log information to the Modemlog.txt file. The Modemlog.txt file is
located in the Windows folder.

The entries in the Modemlog.txt file have the following format:

<Time/Date> <Message/Status Information>

The following is a sample Modemlog.txt file with explanations. Note
that explanations do not appear in an actual Modemlog.txt file. The
contents of an actual Modemlog.txt file may differ greatly from this
sample file.

Sample Modemlog.txt File

05:02:56 05-25-1994 - TI V.32Bis-V17 Internal in use. 05:02:55
05-25-1994 - Modem Type: TI V.32bis-V.17 Internal

A program has called TAPI to open this modem's line handle.
Unimodem.tsp called the Win32 function to open a file handle to
Unimodem.vxd for this modem.

05:02:56 05-25-1994 - 38400,N,8,1

Unimodem has called VCOMM to open the correct serial port for this
modem, and set its default COM port settings.

05:02:56 05-25-1994 - Initializing modem. 05:02:56 05-25-1994 - Send:
AT

Unimodm sends an 'AT' to initialize the modem's autobaud setting.

05:02:57 05-25-1994 - Recv: AT<CR><CR><lf>OK<CR><lf> 05:02:57
05-25-1994 - Interpreted response: OK

The "AT<CR>" is echoed back by the modem, along with an "OK"
response code. Unimodem discards the echoed command, and correctly
interprets the OK response.

05:02:57 05-25-1994 - Send: AT &F0 05:02:59 05-25-1994 - Recv: AT &F0
<CR><CR><lf>OK<CR><lf> 05:02:59 05-25-1994 - Interpreted response: OK

Unimodem sends the first initialization string specified in the
.inf file, discards the echoed command, and interprets the OK response
correctly.

05:02:59 05-25-1994 - Send: AT E0 Q0 V0 W1 T L2 M1 &C1 05:03:01
05-25-1994 - Recv: AT E0 Q0 V0 W1 T L2 M1 &C1 <CR>0<CR> 05:03:01
05-25-1994 - Interpreted response: OK

Unimodem sends the second initialization string from the .inf
file. The command is echoed back, and numeric response codes are now
in use.

05:03:01 05-25-1994 - Send: AT &D2 &S0 X4 %C1 \JO \N7 \Q3 \V1 \T0
05:03:03 05-25-1994 - Recv: 0<CR>

Unimodem successfully sends the third initialization string from
the .inf file. Note that this command is not echoed back by the modem.

05:03:03 05-25-1994 - Send: ATS7=50\T0L2M1%C1\N7\Q3B1X4 05:03:04
05-25-1994 - Recv: 0<CR> 05:03:04 05-25-1994 - Interpreted response:
OK

This is the dynamic initialization stage. Unimodem sent a string
to configure the modem to settings requested by the user or program.
The command string is built dynamically based on registry keys
originally specified by Settings values in the .inf file.

05:03:04 05-25-1994 - Dialing ". 05:03:04 05-25-1994 - Send: ATX4
05:03:06 05-25-1994 - Recv: 0<CR> 05:03:07 05-25-1994 - Interpreted
response: OK

Unimodem first sets dial tone detection on.

05:03:07 05-25-1994 - Send: ATDT; 05:03:09 05-25-1994 - Recv: 0<CR>
05:03:09 05-25-1994 - Interpreted response: OK

Unimodem takes the modem off-hook.

05:03:09 05-25-1994 - Dialing '9555 1212' 05:03:04 05-25-1994 - Send:
ATX4 05:03:11 05-25-1994 - Recv: 0<CR> 05:03:11 05-25-1994 -
Interpreted response: OK 05:03:11 05-25-1994 - Send: ATDT9555 1212;
05:03:15 05-25-1994 - Recv: 0<CR> 05:03:15 05-25-1994 - Interpreted
response: OK

Unimodem dials the phone number provided by the program via TAPI.

05:03:15 05-25-1994 - Originating the call. 05:03:15 05-25-1994 -
Send: ATX3D

Unimodem originates the call.  Note that "X3" is included because
this modem will not work correctly without it. Some modems do not
require this.

05:03:30 05-25-1994 - Recv: 52<CR>77<CR>69<CR> 05:03:30 05-25-1994 -
Interpreted response: Ignore

"Ignore" is misleading.  Here, Unimodem recognized "52<CR>" as a
call progress response code.

05:03:30 05-25-1994 - Recv: 77<CR>69<CR> 05:03:30 05-25-1994 -
Interpreted response: Ignore

Unimodem recognized "77<CR>" as a call progress response code.

05:03:30 05-25-1994 - Recv: 69<CR> 05:03:30 05-25-1994 - Interpreted
response: Connect

Unimodem recognized "69<CR>" as indication of a connection.

05:03:30 05-25-1994 - Connection established at 14400bps. 05:03:30
05-25-1994 - Error-control activated. 05:03:30 05-25-1994 - No data
compression, or modem does not support

            compression reporting.

Unimodem knows that this is a 14,400 bps call with error
compression but no data compression, based on the "52<CR>77<CR>69<CR>"
response codes.

The call is now in progress, in use by the program.

05:03:41 05-25-1994 - Remote modem hung up.

Unimodem detected a carrier loss. The call was disconnected by the
other computer. This output is different if Unimodem is called to
disconnect.

05:03:41 05-25-1994 - Hanging up the modem.

Unimodem dropped DTR to cause the modem to hang up.

05:03:41 05-25-1994 - TI V.32bis-V.17 Internal Closed.

Unimodem.tsp closed its Win32 file handle to the modem.
0
 

Author Comment

by:blakef
ID: 1749933
Hi,

  The suggestion was something that I already tried, but basically, it seems a case of the COM port being there, and being able to send signals 'out', but somehow not getting anything back.  Again, the example is that COM3 & 4 appear OK in the device manager, but seem to fail with all devices (modem being my test/debug device at the moment), but I have tried a mouse and digital camera output as well.

  From the modem log, I see this (the modem works fine on COM1 or COM2):
08-03-1997 20:57:39.95 - TNC MERZ336 HI SPEED FAX MODEM in use.
08-03-1997 20:57:39.96 - Modem type: TNC MERZ336 HI SPEED FAX MODEM
08-03-1997 20:57:39.96 - Modem inf path: MERZ3361.INF
08-03-1997 20:57:39.96 - Modem inf section: Modem1
08-03-1997 20:57:40.21 - 115200,N,8,1
08-03-1997 20:57:40.26 - 115200,N,8,1
08-03-1997 20:57:40.28 - Initializing modem.
08-03-1997 20:57:40.28 - Send: AT<cr>
08-03-1997 20:57:42.28 - Recv: <no response>
08-03-1997 20:57:42.28 - WARNING: Unrecognized response.  Retrying...
08-03-1997 20:57:42.28 - Send: AT<cr>
08-03-1997 20:57:44.29 - Recv: <no response>
08-03-1997 20:57:44.29 - WARNING: Unrecognized response.  Retrying...
08-03-1997 20:57:44.29 - Send: AT<cr>
08-03-1997 20:57:46.29 - Recv: <no response>
08-03-1997 20:57:46.29 - WARNING: Unrecognized response.  Retrying...
08-03-1997 20:57:46.29 - Send: AT<cr>
08-03-1997 20:57:48.30 - Recv: <no response>
08-03-1997 20:57:48.30 - WARNING: Unrecognized response.  Retrying...
08-03-1997 20:57:48.30 - Send: AT<cr>
08-03-1997 20:57:50.30 - Recv: <no response>
08-03-1997 20:57:50.30 - ERROR: Unable to recover from unrecognized response.
08-03-1997 20:57:50.30 - Hanging up the modem.
08-03-1997 20:57:50.55 - Session Statistics:
08-03-1997 20:57:50.55 -                Reads : 0 bytes
08-03-1997 20:57:50.55 -                Writes: 15 bytes
08-03-1997 20:57:50.55 - TNC MERZ336 HI SPEED FAX MODEM closed.

0
 
LVL 2

Expert Comment

by:barthollis
ID: 1749934
I assume you have all the ports at different addresses?

It would appear you have an interrupt conflict.
IRQ 9 is mapped to IRQ 2.

I'm not sure if the Matrox card is one, but many video cards use or reserve IRQ 9.  You can sometimes use it, and sometimes not.  I always try to avoid it if I can.  Try moving the interrupt on your ports 3 and 4 to another number.  10 if your sound card is not there.  11's a possibility if you have no SCSI card.  12 if you have no Net card.  15 if you have only one IDE port.

Avoid 14 (primary IDE port), 6 (floppy controller)  13 (system). _ _ _ 16 interrupts, that ought to be enough for anybody!
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 1

Expert Comment

by:compmech
ID: 1749935
May I add a few variables for you to consider.
Traditionaly COM3 =3e8-3f8,at Irq4 ,COM4 = 2e8-2f8,at Irq3. The I/O card you added has jumpers on it, what have you set them to?
Even though the Irqs are the same as for COM 1 AND 2 they should still work. This is the basic configuration subsequentialy, most often recognized either by hardware or software.


0
 

Author Comment

by:blakef
ID: 1749936
compmech stated: Traditionaly COM3 =3e8-3f8,at Irq4 ,COM4 = 2e8-2f8,at Irq3. The I/O card you added has jumpers on it, what have you set them to?


  The card is set with COM3 address=3E8-3F8, at IRQ 12 (bus mouse turned disabled).  COM4 is addresss=2E8-2F8, IRQ3.  Both ports seem to send data out, but not receive.  Again, using the (external) modem as a query device, I can get info from it with 'more info' tag of the Modem setting, but when I try to dial out, it says not responding.
  At this point I have suspected the card, because I could get this behavior on both 3 and 4, althought I want them on another interrupt so as not to conflict with modem (COM2) and mouse (COM1).  I have taken the card back in, and am waiting to hear a response.  

  One last thing; the card is equipped with 16650 chips, not the 16550 (16 byte FIFO).


Blake
0
 

Accepted Solution

by:
riclim earned 100 total points
ID: 1749937
One way to clear the card is to test it as COM1 & COM2.
In otherwords, disable COM1 & COM2 on your motherboard and then plug in the card appropriately. If the hardware is OK, your normal mouse and modem should work fine.

The next step is to configure the card as COM3 & COM4.
Do this interim step with the default IRQ4 and IRQ3 respectively.
With the mouse at COM2, test the modem at COM3.
With the mouse at COM1, test the modem at COM4.

If you are OK so far, it means that the hardware is OK in general. However, your software (or Win95!) may not support the additional IRQ properly.

At this stage, I would recommend that you leave well alone if the situation is tolerable. On my home system, I have my mouse on COM2, modem on COM1 and HP SJ4s on COM3. Both COM1 & COM3 are on IRQ4. Works fine as long as I do not try to use scanner and modem simultaneously. Also recommended that a re-boot after scanner use to ensure proper modem init (occasional problems, like port in use!).

The other alternative is to use a dedicated software that supports non-standard IRQ (non TAPI). Try your modem on COM3 IRQ9 with say WinFax Pro.

Good luck

0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question