OS/2 Warp 4 and win-os2 sound

I have a soundblaster 16 sound card which I installed in DOS and win-os2 using the drivers which came with the card.
      After a fresh bootup and while starting my first win-os2 session I would get an error message that my soundblaster configuration is at fault and that my soundblaster wave and midi driver was not working.Advice is then given to reconfigure in control panel.However, on shutting down and restarting the session I get no error messages and my win-os2 sound works okay.
      What could be the problem?
NB.I have checked my os/2 config.sys and hardware manager and compared the IRQ and DMA settings with that of the win-os2 sytem.ini file and also autoexec.bat but there are no conflicts.DOS sound is fine.
acmartinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

acmartinAuthor Commented:
Edited text of question
0
avkCommented:
THIS IS AN EXAMPLE
Base Address = 220
irq = 5
lowDMA = 1
highDMA = 5
MIDIport = 330

1)
in your autoexec.bat put the line:
SET BLASTER=A220 I5 D1 H5 P330 T6

2)
in your winos2 system.ini check this part:

[sndblst.drv]
PnpFlag=0
MIDIPort=330
HDmaChannel=5
DmaChannel=1
Int=5
Port=220

Good luck

Arjan
avk@xs4all.nl
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
acmartinAuthor Commented:
I tried this and no go.
Everything seems okay.
0
avkCommented:
try to add this line in your autoexec.bat
[path to sbfiles\]sndinit /b

and check that this line is in your os/2 config.sys

DEVICE=D:\MMOS2\SB16D2.SYS /C:1 /D:1 /H:5 /I:5 /A:220 /M:330 /N:SBAUD1$ /Q /P
DEVICE=D:\MMOS2\AUDIOVDD.SYS SBAUD1$

/c = cardnumber
/d = lowdma
/h = highdma
/i = IRQ
/a = base address
/m = midiport
/d = drivername
/q = quiet mode,
     for checking change this to /v
/p = Initialize PNP mode !!

check that those settings are identical to your "set blaster=..." (autoexec.bat) and the winos2 "system.ini" settings

arjan
avk@xs4all.nl
0
acmartinAuthor Commented:
They are identical.The only thing left to do was to add your statement '[path to sbfiles\]sndinit /b' to my autoexec.bat file which was not accepted on opening a session.
      Anymore ideas? You have reached now where I am stuck and cannot think of what else to do.
      In order to install the sound card in DOS, I had to install the ISA plug and play configuration manager in a DOS session. Could this be the source of the problem?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.