Solved

Virtual Resolution in X windows

Posted on 1997-08-03
5
227 Views
Last Modified: 2013-12-06
I'm using Red Hat ver 4.0 and have got Xfree86 working....I have specifically set up my XF86Config file for an S3 trio PCI chipset and stated under the device sections to try 640 x 480 resolution first..under virtual also. I continue to see a default 320 x 200 resolution and it states that was used when I shut down X:


(***) SVGA default used
(***) virtual 320 200 used

something like this... any suggestions on how to force a 640 x 480 or 400 res?
0
Comment
Question by:ronalddd
  • 4
5 Comments
 
LVL 2

Accepted Solution

by:
n3mtr earned 50 total points
ID: 1626537
Do you have the s3 server installed and have you made the symbolic link to X?

Looks like its using the SVGA server, maybe you have X symbolic linked to the SVGA server by mistake.
0
 
LVL 2

Expert Comment

by:n3mtr
ID: 1626538
BTW X lives in /usr/X11R6/bin/X; it should be a sybmolic link to your s3 server.  Make a symbolic link with ln -s
0
 

Author Comment

by:ronalddd
ID: 1626539
I made the symbolic link to XF86_S3 but my LINUX manual stated to use the 'rm' command first:

            'rm /usr/X11R6/bin/X; ln -s /usr/X11R6/bin/XF86_S3 /usr/X11R6/bin/X'

I did this and now it can't find X; I should have questioned this first...have I lost X forever...after I finally got it working even if it was in SVGA....please any suggestions on recovering X in /bin/ dir???
0
 
LVL 2

Expert Comment

by:n3mtr
ID: 1626540
It sounds like you don't have a link from X to the server, or the  server is missing.
Yes using the rm command(delete) was nessesary to get rid of the old X.  X is just a symbolic link(like a shortcut if you are a windows fan) to the S3 server.  Are you sure you have the s3 server installed(xf86_s3)?  Look around for the server then make the symbolic link. It may be in a different directory.
when you have done it right, doing an ls -l in x11r6/bin should show X then the file it links to.

Let me know if you have any questions
0
 
LVL 2

Expert Comment

by:n3mtr
ID: 1626541
If you want to get your old setup back just make the symbolic link from the svga server.  xf86_svga I think.
rm /usr/X11R6/bin/X; ln -s /usr/X11R6/bin/XF86_SVGA /usr/X11R6/bin/X
Make sure the directories are correct; some distributions move the files around.
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question