system32 folder opens at startup

This started recently. When I start up my machine and log in (Administrator with no password; I'm the only user), my machine runs normally, the icons appear on the desktop, then the system32 folder appears on the screen. I just close the folder and move on. I checked my startup folders and they are empty. Any suggestions would be greatly appreciated.
mrybickiAsked:
Who is Participating?
 
cerConnect With a Mentor Commented:
Here are other places where a program can be loaded at startup in NT:

- In the Startup folder for the current user and all users.
- In the registry:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServices
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce

0
 
shepherdsCommented:
Could this be a Profile problem?
0
 
mrybickiAuthor Commented:
No. I checked all the files. No calls to system32. If you goto Run and type in system32 and press enter, that's what appears on my screen.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
cerCommented:
See also:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows
load REG_SZ and
run REG_SZ

Also, are there any shortcuts (*.lnk) in the system32 folder?


There is another possible reason (Taken from a PAQ):

Explorer (which is also displaying desktop and taskbar) will normally at startup bring up your desktop the same way you left it when you last logged of. If you ever log off with the system32 directory (or anything else) open, next time you log on it will be open again. Normally you clear this by simply closing the folder ynd log off.

If - for some reason - Explorer cannot update the registry, you'll experience problems like the ones you describe.

Check the following and let me know what happens

* If you create a new user account and log on, does the system32 folder show up or not?

* If you log on as administrator and open any other directory from "My computer" and log off with the directory still open, does that directory show up or not if you log on again?



0
 
cerCommented:
OK, last possibility I have:

1. Edit: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer. If the right
hand pane has an entry NoSaveSettings that is a 1, set it to zero until the problem is resolved. This should be a
REG_BINARY value.

2. Edit: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
For each Value, make sure that the string is valid, i.e., if the Value is ActiveMovie File Extensions, the string of this
REG_SZ entry should be ActMovie.exe /Check and not null. The string must always start with an executable file. If it
doesn't, fix it or delete the Value.

0
 
mrybickiAuthor Commented:
I checked the registry directories and they didn't have system32
alone.

I left a folder open and did a full shutdown (turned off the machine). I started it up again and both system32 and the new one opened. I then added a new user and again did a full shutdown. I logged in as the new user and the folders did not appear. I then Crtl-Alt-Del and selected log in as a different user. When I logged in as Administrator the system32 folder appeared but the second one did not.
0
 
cerCommented:
Obviously the Problem is somewhere in the User registry (HKey current user).
You could create a user with admin rights, log in as this user. Copy the userprofile of the "administrator" to a save location and then delete it. Login as admininstrator, you will get (hopefully) a new profile. Copy back all files from the backedup profile, but not ntuser.*
This way the folder should go away, but all programm specific settings are lost too.

So try this first:
- delete the recent documents (rightclick on taskbar, ...)
- dump registry with "regedit /e filename" , load the created file in notepad and search for system32 to find the registry key.

0
 
mrybickiAuthor Commented:
Sorry for the delay in my response. I created a new profile and copied the Admin account data to it. The new account does not have the problem. Since I am the only user of this machine, I am just going to keep the new account and log in with it. Thank you for your assistance.
0
 
alekestCommented:
If you do not find it in the following keys and you are still having \system32 open on your desktop:

HKEY_LOCAL_MACHINE\Software...
HKEY_CURRENT_USER\Software...

Go here:
[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows]
and completely remove the empty string variables 'load' and 'run'

Just the existance of the load and run strings will cause \system32 to open.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.