FTP proxy not working on Mac

I'm having lots of problems doing FTP through a proxy server.



My ISP just setup a proxy server with a port of 80. this proxy server works

for http, gopher, ssl, ftp, and wais. I've entered this data in Internet

Config 1.3. my ISP says there is no userid or password required to use the

proxy. I've tried it with and without my internet id and password.



So my proxy server entry looks like this: proxy.islandnet.com:80





The http proxy works fine. I can access the web from MSIE through the proxy

without any problems. I am having problems with FTP though.



I've tried FETCH, ANARCHIE, and MSIE for FTP. It doesn't work for me. It just

sits there at "Opening Connection" and eventually times out--HELP!



My ISP says it works fine from Netscape on Win95.



Has anyone had any problems with FTP proxy with InternetConfig or mac FTP clients?



Thanks!

LVL 1
themacmanAsked:
Who is Participating?
 
karl_sConnect With a Mentor Commented:
What your ISP has probably setup is an http-only (incoming) proxy, probably squid. This means that you *must* use something like Netscrape to access the proxy in a manner in which it can understand, no matter whether you are trying to ftp a file or use gopher or whatever... try accessing an ftp site using netscrape configured to use the proxy on all services.
0
 
themacmanAuthor Commented:
Yes, this is correct. I received a similar answer from Stairways Software. Though the problem I have is I still had a hard time using ftp through MS IE. I hate using a browser to access FTP sites unless I have to :-)



I've given you a B for your response. Thank you very much.


0
 
karl_sCommented:
If your ISP is using squid, ask them nicely to recompile squid with the socks option on...

just a thought..

Regards
Karl
=8)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.