Solved

HTTP proxy fails to login anonymous FTP server

Posted on 1997-08-18
3
259 Views
Last Modified: 2013-12-25
I'm trying to get HTTP proxy to work with anonymous FTP. On my Web-browser I'll ask  URL ftp://ftp.funet.fi, which is relayed to my proxy (as URL to port 80). My proxy starts FTP-connection OK, gives userid (anonymous) and password (WWWuser@...). At this point FTP-server disconnects (password isn't valid E-mail address).

My browser doesn't send my E-mail to the proxy, so proxy uses somekind of default value. Is there any place in proxy I can configure this (it's IBM Internet Server for AIX 4.2) or should I do it in my browser (Netscape 3.01) ?

IBM support people weren't able to help (at least so far).

Thanks for any help.
0
Comment
Question by:gronja
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 

Expert Comment

by:grendel081997
ID: 1854749
Do you KNOW that the ftp server you are trying to log into isn't recieving the password? Some of them actually want to have your email address and they will not take passwords like "wwwuser@hahahha" or anything that couldn't be real  
0
 

Author Comment

by:gronja
ID: 1854750
I suppose that my question didn't explain enough. I have run trace in proxy and I know what it sends and receives. Server gets the password OK, but it doesn't like that.

Proxy sends as a default password WWWuser@... and my problem was, where I can change this default. I have been able to add domain name after it, so now proxy sends WWWuser@upm-kymmene.com, which is acceptable for the server.

I still have problems with proxy, because it somehow loses file types (text, binary, directory, link) and that way browser is little bit confused. But the original problem is now pathced (not solved :-).

The given answer is poor, because I asked how to change the password, not why I can't log in (that I knew already).
0
 
LVL 1

Accepted Solution

by:
mwwhite earned 100 total points
ID: 1854751
From the options menu, select "Network Preferences". Choose the protocols tab. There should be a checkbox labeled "Send e-mail address as anonymous ftp password", or something like that. If
select that option, all should be well.
0

Featured Post

How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
push Book Today button to right 10 64
Jqeury/JS: Mutiplying the difference in 2 dates and comparing to another number 2 43
WordPress 8 54
calculate days away 11 27
Any business that wants to seriously grow needs to keep the needs and desires of an international audience of their websites in mind. Making a website friendly to international users isn’t prohibitively expensive and can provide an incredible return…
Today, the web development industry is booming, and many people consider it to be their vocation. The question you may be asking yourself is – how do I become a web developer?
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.
The is a quite short video tutorial. In this video, I'm going to show you how to create self-host WordPress blog with free hosting service.

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question