telnet: not working from Netscape Navigator 4.01

When trying to launch a telnet application (e.g. telnet.exe)
from within Netscape 4.01a under Win95 I get a error message "unable to launch apllication! Error code=2".

The entry under Applications reads correctly
"rundll32.exe url.dll,TelnetProtocolHandler %1" as on our other machine where it is working.

(Btw: changing it to invoke telnet.exe or QVTNet terminal directly does not work either...)

I can connect manually to the host with telnet.exe, so no program or resources problem.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

If you set it directly to telnet.exe or QVTNet does it open the application?  What error does it give? If it opens that app, but goes no further try setting it to telnet.exe %1

hutterAuthor Commented:
Setting it directly to QVTNet or telnet.exe (with "%1") gives the same error.

On the other machine where it is working using

"telnet.exe" invokes telnet with no host
"telnet.exe %1" invokes telnet trying to open host                 "telnet://""
"QVTpath/term.exe %1" invokes QVTNet terminal correctly
"rundll32.exe url.dll,TelnetProtocolHandler %l" invokes telnet                 with correct host
I am using 4.02, and if I try to use telnet.exe %1 I do have a problem.  Telnet.exe is a command line program with no switches.  So whatever you put after TELNET it assumes is the host.  For example if you type telnet /? (trying to get help) it will try to  telnet to the host /?.  Of course it fails.  So telnet.exe is not an option.  My current config uses Procomm (a communiations package that I use).  This works, so it looks like my setup is working like your machine that also works.  I wonder if 4.01a has a bug?

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Try this:
1. If you are using a Windows version, go edit, preferences, Navigator, applications and then EDIT the telent entry to show the location of your telnet client. Do not set up a "new type," which will add another entry for telnet that won't work because the first one will be blank.
2. You may need Niffty-Telnet:
If this doesn't work, reject it.
hutterAuthor Commented:
The problem is that it works on one machine and it doesn't on another. Both run Netscape 4.01a, both run Win95 and both have the same command-line in the Preferences tab in Netscape...
Sounds like corrupted DLL's to me.  Try copying the working files from one computer to the other(remember to back up!)

if you want to use QVTNet and it works on the other, try installing it on the first.  If you want to use rundll32.exe url.dll,TelnetProtocolHandler %l then copy the working files from one computer to another.

Since this does tend to indecate corupt DLL's... does everything elese work ok?

any other problems?


and, my most popular motto, WHEN ALL ELSE FAILS, RE-INTSALL ***EVERYTHING***!
That means, uninstall netscape, then reinstall it fresh.  you can backup you bookmarks file, and even you prefs file(but that might copy over the problem)!


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hutterAuthor Commented:
Thanks for the answer. To my regret I can't test the applicability right now as my boss is away on vacation and I don't have access to his machine (which is the one causing the trouble). But I will do so as soon as he returns and grade your answer accordingly.
hutterAuthor Commented:
Sorry that it has taken so long to grade the answer. After my boss was back from holiday I was away for two weeks myself and just today I have been able to check it.

A short review: Netscape 3.01 worked. Netscape 4.01a didn't. Now we have upgraded to 4.03 and it works perfectly. So indeed "reinstalling" fixed the problem, but not as you thought it would. I guess it was a Netscape bug, since Netscape says it the 4.03 Release notes that as of version 4.03 "Telnet URL's work across all systems".
Yes, well, That's another reason to reinstall fresh, you'll also then have the newest version.  Netscape must come out with a new version every 2-4 MONTHS! And for good reason!  That's one reason why it's SOOOOOO much better than MSIE, they come out with a new one only every 8-12 months.  Glad that solved your problem!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.