?
Solved

startup.cmd

Posted on 1997-08-20
3
Medium Priority
?
398 Views
Last Modified: 2013-12-27
I have following problem with Warp 4.
When booting the system, startup.cmd is in foreground until the desktop
is setting up. Once the desktop is up, startup.cmd looses the focus.
This is a problem for me, because i use startup.cmd to load several
processes and an application which has to be in the foreground
automatically.
Even if i lounch my application with /f option, it doesn't get the focus.
With OS/2 2.11, startup.cmd was always in the foreground.
My question:
Is there a way to keep startup.cmd in the foreground during the whole
boot sequence ? Maybe a setting in the config.sys ?

Thanks for your help,
0
Comment
Question by:um95
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 1

Accepted Solution

by:
sbufton earned 200 total points
ID: 1806116
I don't believe that there is any way for you to specify that startup.cmd should be kept in the foreground. What is worth checking, though, is whether you have anything in your Startup folder (inside OS/2 System on the desktop); startup.cmd starts first, then the programs in the startup folder, and each program in the startup folder snatches focus away from the previous program.

I can only think of two ways you could try to make your program come up in the foreground: start it as the last item in startup.cmd *after a pause* long enough to make sure that the desktop has completely started, or move the call to start it out of startup.cmd and put a shadow of the program into the Startup folder, again as the last item.
At the moment, I can't think of a way for you to put a pause in the startup.cmd, though. Perhaps there is some free- or shareware program which would do that.
0
 

Author Comment

by:um95
ID: 1806117
In fact, the real problem after some more tests is:
Even if you launch a program with /f option from startup.cmd after the desktop is up, the /f has no effect.
It seems to be impossible, to launch a program in foreground from startup.cmd after the desktop is up.
0
 
LVL 1

Expert Comment

by:sbufton
ID: 1806118
I guess the problem is that as the desktop starts, the WarpCenter (in Warp 4) and the Launchpad (in Warp 3) get started, snatching the focus away from other programs which were started before.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Just about everyone has an old PC laying around.  Ask anyone in the IT industry, whether they are a professional or play in it as a hobby.  From outdated Desktops to cheap "throwaway" laptops, they are all around and not as hard to "fix up" as you m…
Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question