?
Solved

Linux Networking question

Posted on 1997-08-25
10
Medium Priority
?
288 Views
Last Modified: 2010-03-17
I'm running Linux Redhat 4.1(vanderbuilt) and have managed to set up my PPP so that as root I can dial out in X-windows using the Net config tool.  I am having probs setting this option up for non root users...I've given pppd the following permissions rwsr-xr-x (suid wrapper??) but i am lost from this point on...the net config tool says that a normal user can activate the ppp0 connection but i hear no dial tone or dialing....

tks in advance
0
Comment
Question by:falcon69
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 3

Expert Comment

by:sauron
ID: 1586253
If you make pppd suid root, then all your users should be able to do this.

chmod u+s pppd           (It appears you've already done this)
chown root.root pppd     (This may be the problem)

If this doesn't help, turn on the debug logging in the ppp-options file, and post the output from the messages file when
you try to go online as both root, and a normal user.
0
 

Author Comment

by:falcon69
ID: 1586254
All right, I've checked on that and root is the owner of pppd, however your comment got me thinking and after re-reading my question I'm wondering...what should the permissions be on my
/dev/modem ?? (this is a link to /dev/cua0) right now the permissions on the link and the actual file are r w - r w - - - -
should i adjust these? both files are obviously owned by root.
0
 

Author Comment

by:falcon69
ID: 1586255
oh, btw I can't find the ppp-options file...where should that be?
Sorry I forgot to mention this.
0
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

 
LVL 2

Expert Comment

by:jprohart
ID: 1586256
why don't you use pppd 2.3.1 with dial on demand ?
bye
0
 
LVL 2

Expert Comment

by:n3mtr
ID: 1586257
Are you using the usernetctl wrapper or are you trying to use pppd directly?
I'm using redhat 4.2, I think redhat 4.1 is the same.  I just made a symbolic link from /usr/sbin/usernetctl to /usr/local/bin/ppp.  Now I can start ppp from any user by doing a ppp up.(down by ppp down)
I did not have to change the permisions on anything.
BTW ppp-options is /etc/ppp/options
0
 

Author Comment

by:falcon69
ID: 1586258
I was unable to find a file called "usrnetctl" I didn a "find / -name usrnetctl -print" and came up with nothing, is it possible there is that much of a difference between 4.1 and 4.2? I found a "usrcfg" in "/usr/bin" but don't know if this is the same file?
tks for your input though.
0
 
LVL 2

Expert Comment

by:n3mtr
ID: 1586259
You may want to consider upgrading a few packages to make it work.  I'll see what package its in.  It's much easier.

I tried a month to get it to work in redhat 4.0  It just wouldn't work unless I was root.(tried making the scripts suid root and everything)  The only way was to make a script that called pppd and did everything itself; but it bypassed the redhat configuration stuff.
0
 
LVL 2

Expert Comment

by:nicademus
ID: 1586260
Has anyone thought to investigate the possibility of it being because when a ppp link is started the daemons that be try to write to files, such as the lock file, and a /proc/net/dev file etc.
And these are in directories which are otherwise possibly Root owned.  Just a thought anyway, Running Windows just nwo so I can't try the theory out for unless I disconnect and reboot...=)


Nica.
0
 
LVL 2

Expert Comment

by:n3mtr
ID: 1586261
usrnetctl is in the netcfg package.  Netcfg requires the latest version of python, pythonlib and initscripts.  You may also need to upgrade a few shared libs.  It will let you know when you try to install them.

If you don't know already, /etc/sysconfig/network-scripts contains the scripts the netcfg uses.  For example it calls ifup ifcfg-ppp0 to bring up ppp.  I was never able to get the scripts to work for users other than root.(set user id root doesn't work for some reason)  I think that is why they make the usernetctl wrapper in 4.2
0
 
LVL 4

Accepted Solution

by:
unicorntech earned 60 total points
ID: 1586262
This can be done and you were on the right track - change the perms on /dev/cua1 (or /dev/cua0) depending on the comport you use. This seems to fix the problem.

Jason
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question