Solved

Install & set-up in win95 PWS

Posted on 1997-08-26
6
215 Views
Last Modified: 2008-03-06
I installed perl 5 build 307 to my Personel Web Server, my perl scripts run fine from the command line, but when trying to run from .htm I get the error "HTTP/1.0 404 Object Not Found", what gives?
0
Comment
Question by:mgfranz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 7

Accepted Solution

by:
faster earned 50 total points
ID: 1205760
First, your scripts must be in a directory that has the execute access, you do this by config the PWS.  Next, you should check your registry, under the key "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3Svc\Parameters\Script Map", there should be a value associate ".pl" (or other extension you choose) with "perl.exe %s" or "PerlIS.dll" (the former is better but the latter is faster).

If all these is correct, make sure the url in the html is correct, it should point to "http://127.0.0.1/yourpath/somename.pl".

Hope this help.
0
 
LVL 18

Author Comment

by:mgfranz
ID: 1205761
My cgi-bin directory has world read/execute access, added the .pl extensions to my registry as you suggested, and reset the default script parameters to <default>, now I am asked where I want to save the .pl file...(?)
0
 
LVL 18

Author Comment

by:mgfranz
ID: 1205762
I made a cardinal error... forgot to stop and restart the PWS... once I did this every thing works fine, shoulda remembered this from my UNIX days.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 7

Expert Comment

by:faster
ID: 1205763
Normally you should not assign read to cgi-bin directory.
0
 
LVL 18

Author Comment

by:mgfranz
ID: 1205764
I know, I'm still off line for now, once I get ready to go on line, all permissions will be reset.

Has anyone been able to get FormMail to work with Blat on a PWS?

Thanks,
0
 
LVL 7

Expert Comment

by:faster
ID: 1205765
Yes, I tried blat and it works fine.  But I wrote my own cgi to sendmail because blat has a lot functions (such as attachment) that I don't need which cause some overhead (temporary file)
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have been pestered over the years to produce and distribute regular data extracts, and often the request have explicitly requested the data be emailed as an Excel attachement; specifically Excel, as it appears: CSV files confuse (no Red or Green h…
There are many situations when we need to display the data in sorted order. For example: Student details by name or by rank or by total marks etc. If you are working on data driven based projects then you will use sorting techniques very frequently.…
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question