Cursor problems

Why, when i create a new cursor resource(importing it from the windows cursors), i receive an "Debug assertion failed" when i load that cursor resource(with LoadCursor function) ?
mguedesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MelangeCommented:
You should be using "LoadStandardCursor" to access a predefined Windows cursor. LoadStandardCursor calls the API LoadCursor with NULL as the instance handle, while LoadCursor attempts to figure out which exe or dll the requested resource is located in. It will use this handle in the call to the ::LoadCursor API.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mguedesAuthor Commented:
This answer do not response to my question because i need a personalized cursor. Thanks anyone for the response.

PS: I find the key of the problem: I have loading the cursor resource in the construct of the WINAPP and in that moment the resources are not disponible!!!!!  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Programming

From novice to tech pro — start learning today.