Solved

IRQ conflict between AWE32 and Network card

Posted on 1997-08-30
9
457 Views
Last Modified: 2013-12-23
When I play sound, and use the network at the same time, I have an IRQ conflict, or so it seems: the computer completely goes dead, and I have to issue a cold reboot.
The strange thing is that win95 does not tell me there is a conflict, and even if I reinstall both cards (use autodetect), it still does not change.
If I use an old DOS util (EZstart from SMC), it reports a different IRQ then WIN95 for the network card.
(network card is and SMC ethercard elite 16 ultra)
What do I do to solve this problem?
0
Comment
Question by:gotte
9 Comments
 
LVL 5

Expert Comment

by:johnsavior
Comment Utility
Hi Gotte !,

Usually sound card have the default setting like :
Port Address : 220h
IRQ : 5

Try to reconfigure Port Address & IRQ for your SMC network card by manual (not automaticallly configure), choose the different Port Addr & IRQ.

Unsign "Use automatic settings" options on Setting --> Control Panel --> System --> Device Manager --> Network Adapters --> Properties --> Resources, set :
Interrupt Request : (like you have choose on reconfigure)
Input/Output Range : (idem)

May be you need to trial and error to set parameter Port & IRQ if you meet message "conflict......"  when reconfiguring them.

Good luck !
0
 

Author Comment

by:gotte
Comment Utility
I had been trying your suggestion for the last 3 days already, but the big problem was WHICH IRQ I needed to choose. I now managed to solve the problem by setting my SMC on IRQ 7, and SB on 5 (as normal), but then I had to disable my LPT 1 port. As far as I tried this is the only working solution, if I put my SMC on another (free or occupied) IRQ, it does not seem to work, and the PC crashes after 10-30 seconds when I play sound and Network Neigborhood does not detect other PC's on the network.
Thank you for your time though.

0
 
LVL 5

Expert Comment

by:y96andha
Comment Utility
What if you put your SB on 11 or something like that? I'm not sure what IRQ's can be used, but there must be some other than 5 and 7.
0
 

Expert Comment

by:richyc
Comment Utility
in order to see which IRQ is/are still free, goto system properties, under device manager, click on computer (its usually
selected already) and it will show you which device and using
which IRQ, you have 15 IRQ in a system. so if you see one of the
number is not there, that means its free. 9, 10, 11 are usually
free, if you dont have a scsi or complicated system. and you can
just change your IRQ of your network card to one of these free
one..easy?
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Expert Comment

by:richyc
Comment Utility
I meant to say double click on the "computer"
0
 

Author Comment

by:gotte
Comment Utility
If you put the SB on other IRQ's then 5 or 7, older DOS games
cannot detect it anymore, only games that run in native win95 can use the SB on these non standard SB IRQ's.

about Richyc's answer: I tried all other IRQ's that can be used by the network card (including the free ones), but it does not seem to work correctly. I know enough about computers to say that there is something very strange (not a virus) happening here, it SHOULD work, but for some reason it does not. I've been told Win95 remaps some IRQ's to others, I guess it has something to do with this, but I do not know how or what exactly.


0
 
LVL 4

Expert Comment

by:johnt082197
Comment Utility
Usually, network cards are on IRQ 9. But that might not be an IRQ problem at all. Check you manuals to find if there is any memory pages exclusions on the hardware you are using. Some network cards do that a lot.
0
 
LVL 25

Accepted Solution

by:
dew_associates earned 100 total points
Comment Utility
Gotte: The situation causing your problems is actually in three (and maybe four) parts. Posting your system bios type PnP or Legacy, how your motherboard sets IRQ's and reports them to Windows and your Windows IRQ layout would be helpful but not entirely necessary. It would also be helpful to know whether your network card was PCI or ISA and whether or not it too is PnP capable. Lastly, the AWE32 cards, version 5.6 and earlier were not truly PnP, while 5.8 and later were. You have to determine whether it is or not and how you have it pinned. In any even, First, let's deal with your network card and then we will deal with the sound card. I preface this solution by advising you that (presuming that you are not already aware of it) Windows has a problem with the AWE32 sound card. I have included Microsoft's comments regarding the AWE32 at the end of this answer.
Okay, first things first:
1. Go to the creative labs download site www.nt-ca.creaf.com/wwwnew/tech/ftp/ftp.hmtl and download the latest driver available for your sound card. Expand the file and copy its contents to floppy(ies).
2. . Go to SMC's site and download their latest driver and do the same thing, expand it if necessary and move it to a floppy.
3. Go to device manager and record all of your current IRQ settings and their assignments eg: which devices they are currently set to.
4. Now you have a choice to make, whether you run the cards in ISA/PnP or Legacy under the presumption that both cards are PnP capable. If they are, make sure that both are correctly setup and pinned out for PnP. If either or both are not PnP capable, then select you network card first and go to the next step. Make sure in your CMOS settings that your IRQ & DMA settings are PnP to start.
5. Go to device manager and click on the + sign next to your multimedia entries to expand them. Starting from the last entry to the first, remove each one and verify that you have deleted all of the entries pertaing to your sound card. Then go to add/remove programs and remove your sound blaster software entirely. Shutdown your system and then pull the sound card out of the system. Restart the system and, using windows explorer, remove all of the contents of the sound blasters folders. You can leave the folders, just delete the contents for now.
6. Go to device manager and click on the + next to your network card and expand it. Delete the entries for your network card, then restart your system. When the network card is found by Windows, load the drivers you downloaded and saved to floppy. Verify that your network card functions properly and that you have full access to the network neighborhood.
7. Go back to device manager and note the resource settings for your network card and write them down.
8. Shut down your system again, reinstall your sound card and restart. When windows find the AWE 32 card, use ONLY the downloaded drivers. Go completely through the install process and then test the sound card as well as the network card. IF everything is functioning, then go to device manager and note the resources used for both the network card and the sound card and note any changes from what you have written earlier.
9. Load the creative labs software, but don't let it change driver files with earlier one's.
Some of the noted Windows problems with AWE32 are:
===========================================
When you run the Setup disk for the Sound Blaster AWE32 sound card, you may receive the following error message
We've encountered an error as follows:
       On script line 184 we had a problem:
       Unable to create directory C:\WINDOWS\SYSTEM\<filename>
       Continue installing? "Y" or "N"
where <filename> is Sb16snd.drv, Cspman.dll, or Sbawe32.drv.
After you receive this error message, you receive a series of error messages, including general protection (GP) fault error messages.
The cause:
============
The Windows 95 drivers for the AWE32 sound card were loaded and in use when you tried to run the Setup disk. Some of the drivers were replaced by Windows 3.x drivers from the Setup disk.
The resolution:
=============
Remove the AWE32 sound card in Device Manager and then use the Add New Hardware tool in Control Panel to redetect the sound card.
Note that it may also be necessary to disable lines in the System.ini file that reference the following files before you can redetect the sound card:
Sb16aux.drv
Sb16snd.drv
Sbawe32.drv
To disable these lines, open the System.ini file in any text editor (such as Notepad), and place a semicolon (;) at the beginning of each line you want to disable. After you disable the lines, save the System.ini file and restart Windows 95.

More detailed info:
===============
After you receive the error messages described above, you receive the following error message when you restart your computer:
Sound Blaster AWE32 MIDI Synth VSBPD.386 not installed
When Windows 95 starts, you see a blank desktop. Running a program restores the desktop. Windows 95 seems to work correctly, but trying to use any audio component results in GP fault error messages such as:
MSGSRV32 caused a general protection fault in          MMSYSTEM.DLL
RUNDLL32 caused a general protection fault in SB16AUX.DRV
MMTASK caused a segment not present fault in CSPMAN.DLL
SYSTRAY caused a general protection fault in SB16AUX.DRV
 
Shutting down and restarting the computer results in the following error message:
System File Error - The following system files have been replaced with older versions:
cspman.dll,       sb16snd.drv,       msmixmgr.dll
This is usually followed by a blank desktop and GP faults as described above.
 
Let me know how you make out. If you have trouble, the info requested above would be necessary.
Best regards,
Dennis
0
 
LVL 1

Assisted Solution

by:wdawes
wdawes earned 100 total points
Comment Utility
user gotte wrote:
> <snip>
> I now managed to solve the problem by setting my SMC on IRQ 7, > and SB on 5 as normal), but then I had to disable my LPT 1
> port. As far as I tried this is the only working solution, if I > put my SMC on another (free or occupied) IRQ, it does not seem > to work <snip>
>
Gotte,

     Welcome to the wonderful world of Plug-N-Pray! You said you tried another IRQ (other than 7) and the card would not work. Well, disabling your LPT1 port is not acceptable (what if you get a printer?). Here's what to do:

1. use a higher availble IRQ (10 may be good?) for the AWE32;

OR

2. make the SMC NIC work ...

- Reboot, let Plug-N-Pray do it's auto-detect thing, installing the NIC and the AWE32 with a conflict;

- as suggested above, determine a free IRQ for the SMC NIC, then check the available IRQ settings in your manual, or just go into Ctrl-Panel, Add Hardware, <say No to detect>, SMC, Elite 16 Ultra 8216, ... (and look for the resource choices), write them down, Cancel.

- Go into Ctrl-Panel, System, Device Manager, and find _all_ the yellow exclamation points having to do with the NIC (look in Other, too) ... Remove them. OK.

- Reboot, hit F8 key during "Starting Windows ..." message.

- Goto directory where EZSTART is, and run it. Configure card, if possible to the free IRQ, and use the diagnostics to test it. Save & Exit.

- Reboot, let Plug-N-Pray do it's thing.

- Goto Ctrl-Panel, System, Device Manager, Network adapters, Properties, Resources ... un-check "Use Auto Settings", now select "Change Setting" (change it to the one you tested in EZSTART). OK.

- Reboot.




0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

Have you ever set up your wireless router at home or in the office to find that you little pop-up bubble in the bottom right-hand corner of Windows read "IP Conflict - One of more computers on the network have been assigned the following IP address"…
I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now