We help IT Professionals succeed at work.

Basic about quota and linux

cl071997
cl071997 asked
on
Medium Priority
254 Views
Last Modified: 2010-03-18
Hi.
I´m trying to run quota on my Linux machine. I´m using slakware and got the quota support filesystem and of cource the quota program. When I write 'edquota -u [username]' the wonderful vi shows me 'Quotas for user cl:'. And now...what the heck shall I write here??
Greatful for some help.
Claes Lindvall
Comment
Watch Question

It is not just as easy as compiling the programs and installing them.  You first must edit you /etc/fstab file.  I assume you have not done this.  Here is my /etc/fstab file...
/dev/hda3   swap     swap  defaults                     1   1
/dev/hda2   /        ext2  defaults,usrquota,grpquota      1   1
/dev/hda1   /dosc    msdos defaults,usrquota,grpquota      1   1
/dev/hdc1   /dosd    msdos defaults,usrquota,grpquota      1   1
/dev/hdd1   /dose    msdos defaults,usrquota,grpquota      1   1
none        /proc    proc  defaults                        1   1

As you can see, where I have each partition set up, as yours should look somewhwat vaguely similar, all you need to do here is after the "defaults" add ,usrquota (for a by the user quota) and ,grpquota (for by the group quota) on whichever partition(s) you want to keep tabs on.
Next, in your /etc/rc.d/rc.local add a line quotaon -avug (do a man quota to find out what each flag is)

Now reboot, as long as you had installed the program files, and there were no problems compiling them (if you did so) when you log in you can do the edquota -u username and you should be able to understand it a little better, as long as you know how to use vi !
But before you do the above you must build the Dbase by doing quotacheck -vug {filesys} where filesys might be / for the root, or /dosc for the Dos partition, etc.
  The soft limit is a limit which can be crossed by the user, but they will be warned and then there is a time limit for them to remove there files.  The Hard limit can not be crossed at all.  A handy hint, do not give Root a Quota, unless you like being locked out after forgetting to get rid of stuff!

I hope this helps, if not sorry.

Ps.  You can change the default editor by changing the EDITOR environment.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Thank you. You ought to be in the "HOW-TO"-group.
Now it works.
Claes Lindvall
Thank you, much obligued....=)
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.