Trouble with forwarding.

 I have two linux boxes, (ethernet connection) one I am trying to set up as a router with no luck. (PPP dial on demand / diald installed, works fine). I cannot get this kernel to forward any packets, I compiled all the TCP/IP support there is in the kernel config ( including ip-forward and ip-masq, but must not be working). I can connect to the computer fine (telnet, ftp, nfs...) , but I cannot go threw it. I can connect to the internet fine when on it (telnet'ed to it or direct), but none of my routing/forwarding is allowing me to forward threw it from the other computer. I tried everything from the mini-howto's on the subject with no results. I have the ipfwadm like all the examples. I have all the nessary modules loaded. I have the routing setup like the examples. Why can't I go threw that box!

router computer:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         *      UH    0      0        0 sl0     *      UH    1      0        0 sl1
localnet        *        U     0      0        2 eth0
loopback        *            U     0      0        2 lo
hamnet       UG    0      0        0 sl0
(diald set up sl1, sl0 is tnos, ham radio packet software. it is also not forwarding proberly. pppd will set the default route when it connects)

 ipfwadm -F -p deny
 ipfwadm -F -a m -S -D

other computer:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
localnet        *        U     0      0       27 eth0
loopback        *            U     0      0       14 lo
default         UG    0      0        0 eth0
(musha is the name of the router)

System specs:

router box:
386DX 33, 8 meg RAM, 130 Meg HD

other system:
486DX2 80, 32 meg RAM, 1.2 GIG + 420 Meg HDs

both have LINUX 2.0.30, modules 2.0.0 (all compiled myself)
router main install was Slackware 3.3
other main install was Slackware 3.2 (upgrade from 1.2.13)
I downloaded and reinstalled all the lib's, include files, kernel and modules, and other packages on the other computer. They are not from Slackware.
The router box only has the kernel and modules packages reinstalled.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I may be able to answer but could you elaborate on something, I had some and no luck doing exactly the same thing, If memory serves me...Do you have the router (which I assume uses a slip connection to the net and thena  Ethernet connection to the other computer) set up as a gateway.  i.e. on the  computer which can't connect in the routing table do you have the router's Ethernet IP address as a gateway, something like  route -add gw {router-eth-address} where router-... is the IP address of the Ethernet card.
Also you should know that you should not be connecting an LAN network to the net anyway, unless you have cubscribed for extra IP addresses, this may be why, because you have given the Ethernet on the "can't" computer an address which the Host and therefore Route will not process.
Drop the ipfwadm -F -p deny and it ll work.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
I think you're routing table is wrong. You should have a default route in there. Although when you normally connect with pppd, a default route is added, when the machine in question is a router, I'm not sure how it's going to treat incomign packets when it has no default route set up.

I run an ipmasqerading router doing pretty much the same as you seem to want to do, and my default route is through the gateway on my ISP's end, and the gatewaydevice is set to sl0. When diald brings the link up, the default route becomes the one set by pppd.
jschaefferAuthor Commented:
That did the trick!! After adjusting the route everything works great!
Thanks a lot! Sorry for taking such a long time to respond. Had trouble with this site. ( login, connect problems )
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.