We help IT Professionals succeed at work.

middle mouse button

doron123
doron123 asked
on
Medium Priority
314 Views
Last Modified: 2011-08-18
i'm working on a sun20 with yello pages ,and i connect to the unix via my pc with x-win pro ,only with my login i cannot use the middle mouse button (mark left button ,paste middle button ) ,i had it and its goen ,since i don't know much unix i dont know how to solve this ,can anyone please help me.

thanks ahead
doron amedey
doron-a@vectronics.co.il
FAE
Comment
Watch Question

Actually, the cause of many of the software products for PC that allow you to use X is not because the user is unfamiliar with unix/X but because of some option that is set in the PC software.

Let me begin by stating that I've never worked with x-win pro.  However, most of the PC software products which allow you to use X on the PC come with options for the mouse buttons.  Since most PCs come with a 2 button mouse, the default for the software is usually to emulate a 3 button mouse.  

From your message, it sounds like you do have a 3 button mouse, in which case, the option for the mouse should be changed from "emulate a 3 button mouse" to "use a 3 button mouse" (i.e., go from emulation to actual usage).

Best of luck!

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Clicking the middle button of a mouse can often be emulated on a
two button mouse by clicking both buttons simultaneously. I have
also found that this often works on a 3 button mouse, by clicking
the left and right buttons simultaneously. Try it and see.

Author

Commented:
well I tried to look for the option of the 3 button simulated and
I dont find it ,i have there 3 button mouse ,and when trying both
of the buttons together still i cannot do it [the paste] ,on the unix itself it works .. ,even in the emacs i cannot paste using the middle button ,there was here some unix expert and he couldn't do it as well ... mybe its somthing in the unix /user enviorment settings ,could you please guide me to a solution ,mybe on the unix settings /or if you know to the x-winpro files /settings ...

thanks ahead for the time and help

doron amedey
doron-a@vectronics.co.il
FAE
check your setting on unix with:
   xmodmap -pp
see man xmodmap for details
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.