Iomega SCSI ZIP drive for linux (slackware

I can not seem to get my zip drive to be recognized by linux.  I have recompiled the kernal for scsi support and installed drivers for iomega and aha152x.  The boot screen looks for scsi devices, but finds none.  I am doing all of this without Xfree86.  How do I get linux to access my Zip Drive?
jonbarmoreAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bungholioCommented:
This depends on which model you have. Do you have the parallel port version or the straight SCSI version. You need the IOMega low-level driver if you have the parallel version, the driver for your SCSI adapter (it'd guess aha152x in your case) if you have to SCSI model.

You need the following 3 things compiled in:
- Low level driver (IOMega or aha152x or whatever in the lowlevel section)
- SCSI disk support
- SCSI support (I think you already have)

Could be that you are missing SCSI disk support (check on that). If you have a 2.x kernel you might want to try compiling the first two as modules, then inserting them with insmod in the order above. When I do that for my dad's Zip Drive which I borrow occasionly, it gives some sort of detection message (i don't remember what).

Also, take a look at the ZIP-Drive mini-howto at ftp://sunsite.unc/edu/LDP/HOWTO/mini/ZIP-Drive if this doesn't help.
0
olivier_delcourtCommented:
If you have an Insider SCSI Zip Drive(internal drive, and adaptec 1502 SCSI), I know the answer, because I've one.  Just reject the one from bungholio. I'm expert too and I will answer your question immediately.
0
jonbarmoreAuthor Commented:
I am rejecting the answer because this process doen not work for me.  If any of this info helps, so be it.  I do not use LILO, I use a boot disk.  I have the internal SCSI ZIP drive.  I was told tthat olivier_delcourt could help me.
0
jlmsCommented:
You have to add a boot parameter like this:
aha152x=<PORTBASE>[,<IRQ>[,<SCSI-ID>[,<RECONNECT>[,<PARITY>]]]]

an example, showing the typical values for aha152x card is:

aha152x=0x340,11,7,1

without this parameter Linux will not recognize your SCSI card and by extension your ZIP drive.

If you are using a diskette to boot, then when you are in the boot prompt type whatever you are typing now and include the option previously described in the same line.

Check:

http://sunsite.unc.edu/LDP/HOWTO/SCSI-HOWTO.html

for more information.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
olivier_delcourtCommented:
This is the right answer.  If you have not modified any jumpers on the card since you buy it, here's the line to add to lilo.conf, a file you can find in /etc/.  
append="aha152x=0x140,11,7,1"  Don't forget to type /sbin/lilo to ensure that lilo.conf has been updated.  

Zip disks are partitioned on /dev/sda4


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.