Solved

Installing jdk113.exe on Win95, gives ERROR

Posted on 1997-09-04
17
329 Views
Last Modified: 2013-12-29
Installing jdk113.exe (java developer's kit) on Win95 gives me an error.  It complains about disk space in the TEMP directory.  I have checked the jdk113.exe on another computer and it works.  I have over 300Meg free on my hard drive.  How do I correct the disk space in the TEMP directory and get the jdk113.exe to install correctly?
0
Comment
Question by:seeker090497
  • 8
  • 4
  • 3
  • +1
17 Comments
 
LVL 9

Expert Comment

by:magigraf
Comment Utility
More details please on the computer you are INSTALLING onto...
Ram, CPU, etc...
0
 

Author Comment

by:seeker090497
Comment Utility
I am running on a Pentium 60 with 64Meg Ram. I have two hard
drives giving a total of 2.6G and a 24X CD-ROM
0
 
LVL 9

Expert Comment

by:magigraf
Comment Utility
Did you run scandisk and defrag lately??
0
 

Author Comment

by:seeker090497
Comment Utility
The system disk, where I am installing jdk113 is a new installation of Win95.  I ran scandisk and defrag approximately 2  
weeks ago.  I will do so again, but I do not think that is the
problem.
0
 
LVL 4

Expert Comment

by:johnt082197
Comment Utility
Would that software be using installshield for the install process by any chance?

0
 

Author Comment

by:seeker090497
Comment Utility
Yes it is using installshield.
0
 
LVL 4

Expert Comment

by:johnt082197
Comment Utility
This is a pretty bad answer, I know it. But that's the best I've found:
Installshield does this sometimes. It looks like it enters into conflict with come other application of driver.
So the way to get around the problem is to install a clean version of Windows (even windows 3.1) and start the installation process. Installshield will create directories into your temp dir. As it is doing so, copy them somewhere else so it cannot delete them. Those diretories contain the files needed for the installation. Keep them and, when back to your normal OS, use them to install the software.  That solution worked for Windows 3.1 (even though it was a Windows 95 software, which I hadn't noticed at the time :)). You might be able to skip the installation of a clean environment by doing this in safe mode, but I haven't tried, and right now, I don't have the hard disk space to reinstall 95 to do the test.
0
 

Author Comment

by:seeker090497
Comment Utility
I tried reinstalling the Windows95 OS.  This was not a pleasant
experience.  It is not clear on how, or when it is possible to
save temporary files during this process.  I tried installing another application (Adobe 3.0 Reader) and it failed.  I do not remember the exact words on the error, but it is failing during the decompression phase of the InstallShield process saying that it does not think there is enough disk space to do so.  I ran scandisk and defrag, they did not find any problems.  I have over  
300 Meg free on my system drive and over 400 Meg free on my other drive.
Reinstalling the OS is not an acceptable solution at this time.  There should be other alternatives.  I am increasing the difficulty of the question.  
0
Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

 

Author Comment

by:seeker090497
Comment Utility
Adjusted points to 100
0
 
LVL 25

Accepted Solution

by:
dew_associates earned 100 total points
Comment Utility
Seeker: Uninstall JDK completely and remove it's files and folders. Make sure that you have a good working Windows 95 on your system. Make sure your temp directories are empty, eg: C:\temp if you have or C:\windows\temp or tmp

Using the "ctrl"  -  "atl"  and  "del" keys close all running programs EXCEPT systray and explorer.

Install JDK and follow the prompts as necessary. Once the porgram has loaded, reboot your system and verify it's proper operation.

Please post your results and exactly any errors that occur.

Best regards,
Dennis
0
 

Author Comment

by:seeker090497
Comment Utility
I still get the same error when install jdk113.exe.
It decompressed to approximately 65% then
"The decompression of %s failed.  There may not be enough free disk space available in the TEMP directory."

I have checked the self-extracting archive on another computer and it installs correctly.

Any ideas?
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Seeker: Create another subdirectory on your "C" drive and name it Temp2, it should look like this:

    c:\Temp2

How big is the file being expanded?
How big of a swap file do you have?
Try the install again, but remember to close all running program except "systray" and "explorer" as above. Disable all anti-virus software.

Let me know!
0
 
LVL 4

Expert Comment

by:johnt082197
Comment Utility
What I had mentioned earlier about saving the files while installing should work. What installshiel does is that in decompresses the setup files into your temp dir. you'll probably find a setup.exe, setup.inf, *.hp_, *.dl_...
So empty the temp dir, start installing the sofwate, Alt-Tab to explorer and grab the files as they are being decompressed. Copy them or move them to another dir. Install from that directory. IT WORKED HERE!
0
 

Author Comment

by:seeker090497
Comment Utility
The virtual memory on Win95 was set to auto.
I found a *.swp file in the windows directory
Win386.swp and it was currently set to 4Meg.

The file being decompressed is 9Meg.
 I deceided to check the archive (self-extracting file) with pkunzip for windows.
It detected an error, and created a new zip file.  This new zip
file extracted, and the setup program worked.  I am confused by the archive file.  I decompressed it at work on a WinNT3.51 machine and it worked correctly.  I tried it at home on Win95 and it failed.  I had tried installing Adobe 3.0 (anothher self-extracting file) and it also failed.  I created the c:\temp2 directory without modifiying the TEMP variable in the autoexec.bat.   I removed somesoftware planning to scrub the windows directory, reinstall Win95 and the drivers I need and decided to check the archive with PKUNZIP.  

I have been able to install Adobe without error.  It seems that I have confounded several factors and am not sure of the exact sequence necessary to solve this problem again in the future.  (e.g. disk space, corrupt archive file, or some other unknown.)

Thank you both for your time and ideas.  As my computer seems to be working again, and this is my first question to this forum (experts-exchange) and I am not sure how to close the discussion with two probable solution paths, I am assigning a grade.
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Seeker: You have closed it by accepting the answer, however if there are still concerns, you can add them here or you can e-mail me at dew_associates@msn.com and I will be glad to continue the assistance. That is why we are here!
As to the first issue, Windows NT handles files differently than Windows 95 and is much more liberal than Windows 95 when you open archived or zipped files. You do have me confused though in that, is the file an archived file or a zipped file?
You have done eveything correctly, the cause of your problem was a corrupt file that you fixed using your zip program. You may want to download pkunzip's latest version 6.2, it's shareware.
As for a sequence, there really isn't one as each problem usually has unique characteristics. I normally insure that my system functions in all aspects and is error free. Then I look at the file(s) I am working with to insure that it isn't damaged or corrupt. As for disk space, you can examine a zip file with pkunzip to determine it's expanded size and then determine whether sufficient space is available. Usually having a minimum of 50Mb excess space is a good parameter unless the program being installed requires more.
0
 

Author Comment

by:seeker090497
Comment Utility
I downloaded the java development kit from
www.javasoft.com
The file is
jdk113.exe
a self-extracting executable.  I looked at it with
PKZIP for windows 32bit.

Thanks again. :)
0
 
LVL 25

Expert Comment

by:dew_associates
Comment Utility
Anytime Seeker, anytime!
0

Featured Post

Want to promote your upcoming event?

Attending an event? Speaking at a conference? Or exhibiting at a tradeshow? Easily inform your contacts by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

Join & Write a Comment

Update 11/3/2014 - Although the below article will get you to relocate the WINSXS folder, Microsoft has finally released a utility to reduce the size of the WINSXS folder. For some reason, it's not that straightforward. It only works on Windows 2008…
The use of stolen credentials is a hot commodity this year allowing threat actors to move laterally within the network in order to avoid breach detection.
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now