Solved

disabling autochk

Posted on 1997-09-04
3
855 Views
Last Modified: 2013-12-28
I have a hard drive with a NTFS partition that has some problems. I scheduled CHKDSK to run, but it seems to stuck on verifying index at 39% completion.
Is there a way to disable chkdsk from running automatically at boot. I suppose the system wrote something to the partition table that tells Windows NT to run CHKDSK, because I have tried moving the disk to a different NT system, mounting it as a slave, and CHKDSK still starts automatically.

Help!
0
Comment
Question by:jung
  • 2
3 Comments
 
LVL 2

Expert Comment

by:mearley081497
ID: 1782348
From the MS knowledge base...  It will do the trick

-Matthew

How to Cancel CHKDSK After It Has Been Scheduled

Last reviewed: March 28, 1997
Article ID: Q158675 The information in this article applies to:

•Microsoft Windows NT Workstation versions 3.5, 3.51, and 4.0 •Microsoft Windows NT Server versions 3.5, 3.51, 4.0

SUMMARY

When you run the command CHKDSK /F /R from the command line, Windows NT asks if you want to schedule CHKDSK to run the next time the system is restarted. This article describes how, in the event you choose YES, you can subsequently prevent CHKDSK from running the next time you start the server.


RESOLUTION

To stop the execution of CHKDSK /F /R, you must edit the registry using Registry Editor.

WARNING: Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to reinstall Windows NT to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.

To stop the execution of CHKDSK /F /R, take the following steps:

1.Run the Registry Editor(Regedt32.exe).

2.Under the HKEY_LOCAL_MACHINE subtree, go to the following subkey:

\SYSTEM\CurrentControlSet\Control\Session Manager

3.Change the BootExecute entry from:

autocheck autochk * /r\DosDevice\C:

To:

autocheck autochk *

If you have scheduled CHKDSK for multiple volumes, there will be an autocheck entry for each volume. Delete the string from the BootExecute registry value for each volume you do not want checked.

This procedure will reset the default string, and CHKDSK /F /R will not run on reset.
0
 

Author Comment

by:jung
ID: 1782349
The problem is that CHKDSK wasn't scheduled on the new system that I moved the troubled hd to, so there was no relevant registry entry to edit.

I even tried scheduling a CHKDSK, open up the registry , then look for the BootExecute entry, and found no such entry. There is an entry called Execute, but it doesn't look like it is related.

Jung
0
 
LVL 2

Accepted Solution

by:
mearley081497 earned 200 total points
ID: 1782350
A new disk will be checked in an existing system:

As shown previously - it has worked for me:
 Delete the string from the BootExecute registry value for each volume you do not want checked.

-Matthew
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently Microsoft released a brand new function called CONCAT. It's supposed to replace its predecessor CONCATENATE. But how does it work? And what's new? In this article, we take a closer look at all of this - we even included an exercise file for…
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question