Solved

Second IDE drive won't allow long filenames?

Posted on 1997-09-06
2
141 Views
Last Modified: 2013-12-16
I just installed a 1GB HD and when I pull it up under windows explorer, I cannot create or copy to it files with long files names;  all filenames must conform to DOS filenameing convensions.  How do I get it to accept long file names?  Configuration and installation details follow:

Pentium-90MHz, 24MB RAM, Windows 95 Version 4.00.950
I installed drive on second IDE cable from motherboard,
BIOS recognized it okay and assigned it to D:
FDISKed it as a primary partician,
Formated it from the FORMAT menu item on its icon under MY COMPUTER.
SCANDISKed it fine.
0
Comment
Question by:theowl
2 Comments
 
LVL 7

Accepted Solution

by:
busuka earned 20 total points
ID: 1750400
First of all:
- How BIOS recognise it ? Normal/Large/LBA
 - If it Normal you can't get more 504MB, but looks like you have
   HD works OK. If in 'IDE auto-identification' you specified Large
   change it to LBA and FDISK/FORMAT it immediately after.
   In Device Manager (CtrlPanel-Right_mouse_Click-Properties) remove
   it and let Win95 recognise it again.

If this not helped, post little more info:
 - if you have this HD in 'Compatibility mode' ?
 - What IDE controllers you have in Device Manager ?
 - if this HD shows up at all in Device Manager ?

0
 

Author Comment

by:theowl
ID: 1750401
All is working now.  Thanks!  You got it!

I checked the BIOS configurations again.  It read AUTO-DETECT on all items so I assumed it would work fine.  I changed the translation to LARGE BLOCK since that was an option.  I FDISKed it again, one change here...last time I configured the whole drive as one large 1GB Primary DOS Partician, this time I created a 480MB Primary DOS partician D:, and a 475MB Extended DOS partician with all space in a logical DOS Partician E:(I was told this would cut the minimum cluster size down from 32K to 16K, hence less wasted disk space).  Rebooted.  I then formated both particians from the MS-DOS window.  The E: drive immediately accepted long file names while the D: driver did not.  I re-booted and now both drives accept long file names...Why does LBA allow long filenames versus just LARGE?
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently Microsoft released a brand new function called CONCAT. It's supposed to replace its predecessor CONCATENATE. But how does it work? And what's new? In this article, we take a closer look at all of this - we even included an exercise file for…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

912 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now