Context-Type in ASP Result Files

Hi,

I'm creating active server (ASP) pages using visual studio'97 connecting

to IIS 3.0 running on an NTAS PC.  I'm trying to change my context-type
to produce a comma delimited file (text-plain for testing).  No matter
what I write from my ASP file I am always getting the following two
problems:

1) this line is added to the top of my results page:
        <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">

2)  All of my double quotes have been changed to &quot;

Is there some type of auto format that either visual studio or IIS is
doing?

Any ideas/comments would be appreciated.

Thanks,
Sheldon
shwoodAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KallistiCommented:
An obvious solution is to manually edit the
specific ASP file.  If you get whatever
program you are using to create the basic
template, and then rip out the extra code
that it has put in.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shwoodAuthor Commented:
The addition of this code seems to happen during the  "releasing" of the working copy to the sever.  I beleive that the front page server extensions running on the web server are doing it.  Is there a setting that I'm unaware of?
0
KallistiCommented:
Frontpage does not play with the actual asp/htm/whatever
files once they have been written.  It does however play
around with them a lot if you use it to design them!

Try opening the .asp file up in notepad, and have a look
at it.  Clean it up manually, and make sure everything is
OK before publishing it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.