Modem Connection

I have a US.Robotics Sporster 56K modem.
Since I've used Windows 95, I plug my modem as PNP which means I did not put any pin set.
Now I try to make a connection with Linux through phone
call whuch use PPP tech. I even did not hear any sound
from my modem.
How can I make my modem work?
DaemonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlmsCommented:
Linux does not support PnP (in principle).
There are a series of different tools to overcome this problem, check the Re Hat's site:
www.redhat.com

THey have been hosting the project to include PnP support in Linux, the most famous utility to do so is called isapnp.

   Note that the development is constrained to few devices and actually the authors will like to hear experiences with as many devices as possible.

You can also try disabling the PnP capabilities of your card, Linux shoul recognize it without PnP but can make your life difficult in W95 because you need support now for the card in "normal" (not PnP) mode.
0
DaemonAuthor Commented:
If I turn off Pnp mode which means I set com port and IRQ etc,..
How can I use my modem in Linux.
I am going to set COM3, can you give me the way that I can make
a connection. I am useing Slackware 3.1(kernel2.0)
0
unicorntechCommented:
Use a program called dip to connect.

Type dip -t
then port /dev/cua2
then term
then atdt(provider no.)
this should start the modem ringing and connect you.

Alternatively you could use a chat script eg pppd connect /dev/cua2 defaultroute 'chat "" ATDT(provider no.) ogin: your_login word: your_password'

need more help e-mail me at jsons@aone.com.au

Regards,

Jason
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nicademusCommented:
Daemon,
      All you need to do is edit the file in your /usr/sbin directory called ppp-on i.e.

pico /usr/sbin/ppp-on

change the things which are relevant to you, such as your username and password, and your dial-in number also if you have a permanent IP address put it in, Then down the bottom somewhere look for a section like this, or something a bit similar  You need to change the bit, where in mine it says /dev/cua2 .  Well it so happens that if your modem is on COM3 then the bit which says something like /dev/cua1 or similar needs to be /dev/cua2 also change the speed setting somewhere in that script, to 115200 or 56700 to take advantage of your modems compression abilities.

exec /usr/sbin/pppd debug lock modem crtscts /dev/cua2 115200 \
        asyncmap 20A0000 escape FF kdebug 0 $LOCAL_IP:$REMOTE_IP \
        noipdefault netmask $NETMASK defaultroute connect $DIALER_SCRIPT


THEN:  You just have to execute that script file!  As long as you have an Internet Service provider to give you ppp-access then you should be home free.=) To turn off the script just type ppp-off and it will hang up.

Also In later Kernels PnP is supported by Slakware. such as my 2.1.52 which is very stable so far, and nothing is spared as far aas funtionality goes.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.