windows title???

i want to know 2 things :
1.) when running xterm ,cmdtool how can i set the window name and its icon name (of the program running inside) ,to be displayed ,if i have 7 windows open i can't know which window is running what program ... how can i set this option
.... automatically and not each time manualy (-n switch for the xterm).

2.) the points here for question ,when do they get reseted ,after i ran out of points i can't ask anymore q. for how long ,or what should i do to reset them back to their initial value?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

csh syntax:
 switch ($term)
 case sun:
 case sun-cmd:
    alias back      "echo -n '^[[6t' > /dev/ttyp\!*"
    alias close     "echo -n '^[[2t' > /dev/ttyp\!*"
    alias front     "echo -n '^[[5t' > /dev/ttyp\!*"
    alias open      "echo -n '^[[1t' > /dev/ttyp\!*"
    alias ttytext   'echo -n "^[]l\!*^[\^[]L\!*^[\">`tty`'
 case hpterm:
    alias ttytext   'set ll = `echo "\!*" | awk "{print length}"`;echo -n "^[&f0k${ll}D\!*"; unset ll'
 case iris-ansi*:
    # buggy: does not support window settings
    alias ttytext   'echo -n "^[]2;\!*^G"'
    alias ttytitle  'echo -n "^[]2;\!*^G"'
 case dtterm:
 case linux:
 case xwsh:
 case xterm:
    alias ttytext   'echo -n "^[]0;\!*^G"'
    alias ttyname   'echo -n "^[]1;\!*^G"'
    alias ttytitle  'echo -n "^[]2;\!*^G"'

take care about
   ^G  and  ^[
they are ASCII 0x07  and  ASCII  0x1b

Good luck

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
doron123Author Commented:
how do i write the ascii 0x07 and 0x1b in the unix i don't know ,in the pc i know you press the Ctrl+the ascii number .
could you please tell me ....
depends on your editor, in vi for example use:
  ^V^G            Ctrl-V followed by Ctrl-G
  ^VESC         Ctrl-V followed by ESC

In a shell it can be more tricky, try to type the chars as is, just the CTRL-G itself
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

doron123Author Commented:
i uses the emacs ,shouid i write there ctrl+g ?
emacs, I can't give **you** this answer, because this depends highly on your personal emacs configuration/settings.
I suggest using vi, it's pretty simple:
i  for insert, then type your text, ESC to end your input, then :wq to save and quit (but this is not subject to this question:)
doron123Author Commented:
i get when running source .scrc
breaksw: endsw not found.

what is it ,what should i do to fix it?
you've forgotten the   endsw   command.

Uups, may be you've a Copy/Paste  problem:
there is **exactly** one line between  case hpterm:  and  breaksw
doron123Author Commented:
i only wrote from :case sun till the hp(not including the hp),and tthe xterm case so i have 2 cases and 2 breaksw and one endsw.

i didn't write the hp ect since im working on the sunos and xterm ,is this ok ...?
but still i think i covered the breaks and end sw ,so why do i still get breaksw: endsw not found ??

thanks for the fast and efficient help
Hmm, no idea.
You may send your script to
doron123Author Commented:
i added it to the .cshrc someone here told me that its not for the c shell ...? is this correct?

please help me i must have an answer...

Yes, sounds good.
As I wrote it is csh syntax, so $HOME/.cshrc is a good place.
doron123Author Commented:
i deleted one breaksw and now when sourcing the .cshrc i don't get the error i got ,but still it doesn't work....

how do i make it work ???

Hey, csh is like C (C-shell:-), so in worst case you get the wrong settings.
It's best if you send your script or give me a email address.
doron123Author Commented:
ok its better ,my e-mail add. is

id love to send you my cshrc so you could check it ,and that could save us a day of assumptions.

thanks ahead doron amedey
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.