Excluding 'vti_...' directories in MS Index Server seach

How do you exclude an MS Index Server query form from searching all the 'vti_' sub directories under the virtual directory you are searching (as defined by CiScope in the .idq file).
tomboAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cdittoCommented:
Try specifying:
   CiScope=/YourVirtualDirectory/vti_*
in your .idq file
0
tomboAuthor Commented:
This did not work - it brings back nothing.


MS FAQ for IIS says extending the CiRestriction parameter to

CiRestriction=%CiRestriction% AND NOT #path /path/_vti_cnf*

But this made no difference either. This way seems more logical/correct but it doesn't add any extra restriction.

I have the Scope at /virtual root  and this does search only that directory but still have not found a way to exclude child directories from the search.

Any other ideas?
0
Technocrat062397Commented:
In the IIS 3.0 admin make the catalog.vci directory a virtual directory.  Then use the index server  admin to tell it not to index it.  Be sure to give the directory execute permissions though.  This Works.  Or use the registry to exclude the file extensions contained withen those files not to be index.  I'll look up the registry path and post it when I find it.

Or turn off the system permissions in the directories you do not want searched and then reindex the site


ben@brysonweb.com
0
Technocrat062397Commented:
Unforntuntally there is no way to do that unless you make a really long restrictions in your idq files.  something that looked like this
----------------------------------------
Cirestriction1=%cirstriction%  From User
Cirestriction2=and not path #c:\Insert path* and not path c:\Instert path* (add another and not for every sub directory there is)
CiRestriction= %CiRestriction1% %CiRestriction2
------------------------
That is not the way to go.  What you need to do is move the vti_ directories outside of wwwroot make a virtual directory pointing to them.  Then tell index server administration not to index that virtual directory.
---------------------------------------------------------------

Here are some other ideas

set the following registry key

Hkey_Local_Machine\system\CurrentControlSet\Control\contentindex\
Filterfileswithunknownextensions=0  (this will turn off all file filtering for files with unknown extensions like the ones in the Vti directories)filterdirectories=0  (this will not filter directories as part of index server)
--------------------------------------------------------------
Turning off the sytem permissions is still the best way to go.  I do this for all directories that I don't want indexed.  just go to the properties/security and remove the user (system) and next time you reindex the files will not be found.

Or you could set the permissions on the vti directories to authentacated users instead of everyone.
-------------------------------------------------------------
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.